Light OJ 1094 Farthest Nodes in a Tree(树的直径模板)

Farthest Nodes in a Tree
Time Limit: 2000 MS      Memory Limit: 32768 KB      64bit IO Format: %lld & %llu

Description

Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output

For each case, print the case number and the maximum distance.

Sample Input

2

4

0 1 20

1 2 30

2 3 50

5

0 2 20

2 1 10

0 3 29

0 4 50

Sample Output

Case 1: 100

Case 2: 80

思路:从0节点开始dfs出一条最长的路径(因为是求树的直径,肯定是两条最长边,但又不能确定都是经过0的,所以先dfs出其中一条),以该路径叶节点作为根,再dfs出最长路径。

 代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
const int MAX=30000+10;//这样定义较好,用define会出现runtime error;
int dis[MAX];//存储最长路;dis[i]表示到i的最长距离; 
int head[MAX];
bool vis[MAX];//标记数组; 
int node; //找寻最长路s-t的端点; 
int edgenum;//总边数;
int ans;//最终结果; 
struct Edge
{
	int from,to,value,next;
} edge[MAX*2];
void init()
{
	memset(head,-1,sizeof(head));
	edgenum=0;
}
void add(int u,int v,int w)
{
	edge[edgenum].from=u;
	edge[edgenum].to=v;
	edge[edgenum].value=w;
	edge[edgenum].next=head[u];
	head[u]=edgenum++;
}
void BFS(int s)
{
	memset(vis,false,sizeof(vis));
	memset(dis,0,sizeof(dis));
	queue<int>q;
	q.push(s);
	ans=0;
	dis[s]=0;
	vis[s]=true;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		for(int i=head[u];i!=-1;i=edge[i].next)
		{
			int v=edge[i].to;
			if(!vis[v])
			{
				if(dis[v]<dis[u]+edge[i].value)
				{
					dis[v]=dis[u]+edge[i].value;
				}
				if(ans<dis[v])
				{
				    ans=dis[v];
                    node=v;
				}
				vis[v]=true;
				q.push(v);
			}
		}
	}
}
int main()
{
	int t,n,i,k=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		init();
		for(i=1;i<=n-1;i++)
		{
			int u,v,w;
			scanf("%d%d%d",&u,&v,&w);
			add(u,v,w);
			add(v,u,w);
		}
		BFS(0);//找最长路s-t的端点; 
		BFS(node);//从端点查询最长路距离; 
		printf("Case %d: %d\n",k++,ans);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值