杭电-3665 Seaside (判断后找最短路)

Seaside

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1373    Accepted Submission(s): 988

Problem Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.
 
Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers SMi and LMi, which means that the distance between the i-th town and the SMi town is LMi.

Output
Each case takes one line, print the shortest length that XiaoY reach seaside.

Sample Input
  
  
5 1 0 1 1 2 0 2 3 3 1 1 1 4 100 0 1 0 1
 
Sample Output
  
  
2
这道题主要就是题意的理解,首先输出小镇的数目,从0-n-1小镇开始,首先输入路的数目,然后是小镇的位置,如果是0,只要后面的距离就行;
如果是1,将该小镇统计到数组中。然后是m条路,以及对应的时间;最短路径遍历一边就行了;,从0开始找最短路径,所以这里用dijkstra算法比较简单。
#include<cstdio>  
#include<cstring>  
#define INF 0x3f3f3f   
int map[20][20],dis[20],n; 
int vis[20];  
void dijkstar()  
{  
     
    int i,j;  
    for(i=0;i<n;i++)  
    {  
        dis[i]=map[0][i]; 
    }  
    memset(vis,0,sizeof(vis));
    vis[0]=1;  
    for(i=0;i<n;i++)  
    {  
        int M=INF,k=-1;  
        for(j=0;j<n;j++)  
        {  
            if(!vis[j]&&M>dis[j])  
            {  
                k=j;  
                M=dis[j];  
            }  
        } 
		if(k==-1)
		return ;
		else 
        vis[k]=1;  
        for(j=0;j<n;++j)  
        {  
            if(!vis[j]&&dis[j]>dis[k]+map[k][j])  
               dis[j]=dis[k]+map[k][j];  
        }  
    }  
}  
  
int main()  
{  
    int i,j,end[10],num,d,k,sea,place;  
    while(scanf("%d",&n)!=EOF)  
    {  
        for(i=0;i<n;++i)  
        {  
            for(j=0;j<n;++j)  
            {  
                if(i==j)  
                  map[i][j]=0;  
                else  
                  map[i][j]=INF;  
            }  
        }  
        k=0;  
        for(i=0;i<n;++i)  
        {  
            scanf("%d%d",&num,&sea);  
            if(sea)  
              end[k++]=i;//将在海边小镇存入数组   
            for(j=0;j<num;++j)  
            {  
                scanf("%d%d",&place,&d);  
                if(map[i][place]>d)  
                   map[i][place]=d;//注意是单向图   
            }  
        }  
        dijkstar();  
        int ans=INF;  
        for(i=0;i<k;++i)//找到到海边最短的路径权值   
        {  
            if(dis[end[i]]<ans)  
               ans=dis[end[i]];  
        }  
        printf("%d\n",ans);  
    }  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值