杭电-5137How Many Maos Does the Guanxi Worth(删点枚举+最短路)

How Many Maos Does the Guanxi Worth

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1947    Accepted Submission(s): 751

Problem Description
"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you." or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.
Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.
You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
 
Input
There are several test cases.
For each test case:
The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30, 3 <= M <= 1000)
Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.
The input ends with N = 0 and M = 0.
It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.
 
Output
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.
 
Sample Input
  
  
4 5 1 2 3 1 3 7 1 4 50 2 3 4 3 4 2 3 2 1 2 30 2 3 10 0 0
 
Sample Output
  
  
50 Inf
 
Source
 
Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5803  5802  5801  5800  5799 

不知道怎么删点求最短路径?参考了一下别人的代码,写的挺容易懂得,借鉴一下:

#include<cstdio>  
#include<cstring>  
#define INF 0x3f3f3f  
#define maxn 35  
#define maxm 1010  
int map[maxn][maxn],dis[maxn],n;  
int s[maxm],e[maxm],d[maxm];  
int vis[maxn];
void dijkstar()  
{  
   int i,j;  
    for(i=1;i<=n;i++)  
    {  
        dis[i]=map[1][i]; 
    }  
    memset(vis,0,sizeof(vis));
    vis[1]=1;  
    for(i=0;i<n;i++)  
    {  
        int M=INF,k=-1;  
        for(j=1;j<=n;j++)  
        {  
            if(!vis[j]&&M>dis[j])  
            {  
                k=j;  
                M=dis[j];  
            }  
        } 
		if(k==-1)
		return ;
		else 
        vis[k]=1;  
        for(j=1;j<=n;++j)  
        {  
            if(!vis[j]&&dis[j]>dis[k]+map[k][j])  
               dis[j]=dis[k]+map[k][j];  
        }  
    }  
}  
  
int main()  
{  
    int m,i,j,a,b,c;  
    while(scanf("%d%d",&n,&m)&&n||m)  
    {  
        for(i=1;i<=n;++i)  
        {  
            d[i]=INF;//初始化储存权值的零时数组   
            for(j=1;j<=n;++j)  
            {  
                if(i==j)  
                  map[i][j]=0;  
                else  
                   map[i][j]=INF;  
            }  
        }  
        for(i=0;i<m;++i)  
        {  
            scanf("%d%d%d",&a,&b,&c);  
            if(map[a][b]>c)  
               map[a][b]=map[b][a]=c;  
        }  
        int sign=0;  
        int ans=-1;  
        for(i=2;i<n;++i)//从2到n-1,分别删去每个点   
        {  
            for(j=1;j<=n;++j)//遍历当前点与那些点相连   
            {  
                if(map[i][j]!=INF&&i!=j)  
                {  
                    d[j]=map[i][j];//记录要删去的边的权值   
                    map[i][j]=map[j][i]=INF;//删去当前点的边   
                }  
            }  
            dijkstar();  
            if(dis[n]==INF)//判断删除当前点后是否连通   
            {  
                sign=1;  
                break;  
            }  
            if(dis[n]>ans)//若连通记录下最大的最短路径权值   
               ans=dis[n];  
            for(j=1;j<=n;++j)//遍历当前点与那些点相连   
            {  
                if(d[j]!=INF)  
                {  
                    map[i][j]=map[j][i]=d[j];//还原当前点的边的权值   
                    d[j]=INF;//清空记录的权值   
                }  
            }  
        }  
        if(sign)  
           printf("Inf\n");  
        else  
           printf("%d\n",ans);  
    }  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值