HDU - 5137 How Many Maos Does the Guanxi Worth

How Many Maos Does the Guanxi Worth

Problem Description
"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you." or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.


Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.


You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
 


Input
There are several test cases.


For each test case:


The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30, 3 <= M <= 1000)


Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.


The input ends with N = 0 and M = 0.


It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.
 


Output
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.
 


Sample Input
4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0
 


Sample Output
50
Inf
 


Source

2014ACM/ICPC亚洲区广州站-重现赛(感谢华工和北大)


题意:有N个点,M条边。输入保证至少有一条从1到N的路径,现在问删除任意一个非1和N的结点后还能否有从1到达N的路径,如果有则输出删除这里结点后

求出的1到N的路径的最短路的最大值,否则输出INF 。

思路:暴力枚举删除每一个顶点,对于删除的顶点,我们在求最短路时候不更新该顶点即可,注意如果用Dijkstra的话,K要预处理赋值为1,不然可能在删除顶点

后,找不到下一个顶点导致RE,还有边是双向的。


#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
#define INF 0x3f3f3f3f
const int MAXN = 35;
int n, m;
int map[MAXN][MAXN];
int dist[MAXN], vis[MAXN];
void Dijkstra(int del)
{//删除某个点后求最短路
	memset(dist, INF, sizeof(dist));
	memset(vis, 0, sizeof(vis));
	dist[1] = 0;
	for (int i = 1; i <= n; i++)
	{
		if (i == del)//不更新删除的点
		{
			continue;
		}
		int k=1, mindist = INF;//注意K预处理为1!!不然删除结点后可能K就无值
		for (int j = 1; j <= n; j++)
		{
			if (!vis[j] && dist[j] < mindist)
			{
				k = j;
				mindist = dist[j];
			}
		}
		vis[k] = 1;
		for (int j = 1; j <= n; j++)
		{
			if (j == del)//不更新删除的点
			{
				continue;
			}
			if ( mindist + map[k][j] < dist[j])
			{
				dist[j] = mindist + map[k][j];
			}
		}
	}
}
int main()
{
	while (scanf("%d %d", &n, &m) && n&&m)
	{
		int u, v, w;
		memset(map, INF, sizeof(map));
		while (m--)
		{//注意双向吧
			scanf("%d %d %d", &u, &v, &w);
			map[u][v] = min(map[u][v], w);
			map[v][u] = min(map[v][u], w);
		}
		int maxdist = -1;
		bool flag = true;//若有删掉一个点不能到达则为false
		for (int i = 2; i <= n - 1; i++)
		{
			Dijkstra(i);
			if (dist[n] == INF)
			{
				flag = false;
			}
			else
			{//更新最短路的最大值
				maxdist = max(maxdist, dist[n]);
			}
		}
		if (flag)
		{
			printf("%d\n", maxdist);
		}
		else
		{
			printf("Inf\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值