素数的简单应用

A -- Alarm

Time Limit:1s Memory Limit:128MByte

Submissions:212Solved:74

DESCRIPTION
Given a number sequence [3,7,22,45,116,...][3,7,22,45,116,...]. Please tell me the kk-th number.
INPUT
A number T (T<100)T (T<100) indicates the number of the input cases. Then for each case there only is one integer k (1k10000)k (1≤k≤10000).
OUTPUT
For each case, ouput the kk-th number of the sequence in one line.
SAMPLE INPUT
2
1
4
SAMPLE OUTPUT
3
45
这道题主要就是找出来规律:素数的平方-n;
#include<stdio.h>
#include<string.h>
#define G 1100000
int sushu[G+2];
int k=0;
long long a[G+2];
void init()
{
	int i,j;
	memset(sushu,0,sizeof(sushu));
	sushu[0]=sushu[1]=1;
	for(i=1;i<G;i++)
	{
	   if(sushu[i]==0)
		{
			a[++k]=i;//储存素数;
		}
		if(sushu[i]==1)
		 continue;
		for(j=2*i;j<G;j=j+i)
		 sushu[j]=1;	  
	}
}
int main()
{
	int t,n;
	scanf("%d",&t);
	init();
	while(t--)
	{
		scanf("%d",&n);
		printf("%lld\n",a[n]*a[n]-n);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值