UVA 10200 Prime Time (素数判定打表)

UVA 10200 Prime Time(简单素数判定预处理)

标签:

Euler is a well-known matematician, and, among many other things, he discovered that the formula n 2 + n + 41 produces a prime for 0 ≤ n < 40. For n = 40, the formula produces 1681, which is 41 ∗ 41. Even though this formula doesn’t always produce a prime, it still produces a lot of primes. It’s known that for n ≤ 10000000, there are 47,5% of primes produced by the formula! So, you’ll write a program that will output how many primes does the formulaoutput for a certain interval.

Input

Each line of input will be given two positive integer a and b such that 0 ≤ a ≤ b ≤ 10000. You must read until the end of the file.

Output

For each pair a, b read, you must output the percentage of prime numbers produced by the formula in this interval (a ≤ n ≤ b) rounded to two decimal digits. SampleInput

0 39

0 40

39 40

Sample Output

100.00

97.56

50.00

 

#include<stdio.h>
#include<math.h>
#include<algorithm>
#include<string.h>
using namespace std;
#define G 11010
int num[G];
int sushu(int n)
{
    int k = sqrt(n); //这里用n/2超时
    for(int i = 2 ; i <= k ; i++)
    {
        if(n % i == 0)
            return 0;
    }
    return 1;
}
void init()
{
	num[0]=1;
    for(int i = 1 ; i <G ; i++)
        num[i] = num[i - 1] + sushu(i * i + i + 41);
}
int main()
{
    int a, b,sum;
    double p;
    init();
    while(scanf("%d%d", &a, &b)!=EOF)
    {
        sum= num[b] - num[a] + sushu(a * a + a + 41);
        //printf("***%d****\n",sum);
        p=(double)sum/(b-a+1)*100+ 1e-8;//这里如果不提高精度,会WA;
        printf("%.2f\n",p);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值