poj日记(1860)

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BAand C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

我们的城市有几个货币兑换点。让我们假设每一个点都只能兑换专门的两种货币。可以有几个点,专门从事相同货币兑换。每个点都有自己的汇率,外汇汇率的A到B是B的数量你1A。同时各交换点有一些佣金,你要为你的交换操作的总和。在来源货币中总是收取佣金。

例如,如果你想换100美元到俄罗斯卢布兑换点,那里的汇率是29.75,而佣金是0.39,你会得到(100 - 0.39)×29.75=2963.3975卢布。

你肯定知道在我们的城市里你可以处理不同的货币。让每一种货币都用唯一的一个小于N的整数表示。然后每个交换点,可以用6个整数表描述:整数a和b表示两种货币,a到b的汇率,a到b的佣金,b到a的汇率,b到a的佣金。

nick有一些钱在货币S,他希望能通过一些操作(在不同的兑换点兑换),增加他的资本。当然,他想在最后手中的钱仍然是S。帮他解答这个难题,看他能不能完成这个愿望。

 

输入数据:

第一行四个数,N,表示货币的总数;M,兑换点的数目;S,nick手上的钱的类型;V,nick手上的钱的数目;1<=S<=N<=100, 1<=M<=100, V 是一个实数 0<=V<=103

接下来M行,每行六个数,整数a和b表示两种货币,a到b的汇率,a到b的佣金,b到a的汇率,b到a的佣金(0<=佣金<=102,10-2<=汇率<=102

 

输出数据:

如果nick能够实现他的愿望,则输出YES,否则输出NO。

 

样例输入:

3 2 1 20.0

1 2 1.00 1.00 1.00 1.00

2 3 1.10 1.00 1.10 1.00

 

样例输出

YES

import java.util.Arrays;  
import java.util.Scanner;  
  
import org.omg.CORBA.DoubleSeqHolder;  
import org.omg.CORBA.PUBLIC_MEMBER;  
  
public class Main {  
  
    Scanner cin = new Scanner(System.in);  
    int  v, e, sour;  
    double startMoney;  
    Edge[] eEdgeInfo;  
    double[] dDistance;  
      
    public void input()  
    {  
        int k =0;  
        int a,b;  
        double rab,cab,rba,cba;  
        //System.out.println("输入问题初始化数据");  
        v =cin.nextInt();  
        e = cin.nextInt();  
        sour = cin.nextInt();  
        startMoney = cin.nextDouble();  
        eEdgeInfo = new Edge[e*2];  
        dDistance = new double[v+2];  
        Arrays.fill(dDistance, 0);  
        dDistance[sour] = startMoney;         
          
        for (int i = 0; i < e; i++) {  
            a = cin.nextInt();  
            b = cin.nextInt();  
            rab = cin.nextDouble();  
            cab = cin.nextDouble();  
            rba = cin.nextDouble();  
            cba = cin.nextDouble();  
            eEdgeInfo[k] = new Edge();  
            eEdgeInfo[k].a =a;  
            eEdgeInfo[k].b = b;  
            eEdgeInfo[k].rate = rab;  
            eEdgeInfo[k].commission = cab;  
            k++;  
            eEdgeInfo[k] = new Edge();  
            eEdgeInfo[k].a =b;  
            eEdgeInfo[k].b =a;  
            eEdgeInfo[k].rate = rba;  
            eEdgeInfo[k].commission = cba;  
            k++;                  
        }         
    }  
      
    public int bellman_Ford() {  
        input();  
        int nflag = 0;  
        int nChange = 0;  
        double temp = 0;  
          
        for (int i = 0; i < v-1; i++) {  
            nChange = 0;  
            for (int j = 0; j < e*2; j++) {  
                temp = (dDistance[eEdgeInfo[j].a] - eEdgeInfo[j].commission)*eEdgeInfo[j].rate;  
                if (dDistance[eEdgeInfo[j].b] < temp ) {  
                    dDistance[eEdgeInfo[j].b] =temp;  
                    nChange = 1;  
                      
                }  
            }  
            if (nChange == 0) {  
                break;  
            }  
              
        }  
        for (int j = 0; j < e*2; j++) {  
            if (dDistance[eEdgeInfo[j].b] < (dDistance[eEdgeInfo[j].a] - eEdgeInfo[j].commission)*eEdgeInfo[j].rate) {  
                nflag = -1;  
                break;          //有正权回路  
                  
            }  
        }  
          
  
        return nflag;  
    }  
      
    public void solve()  
    {  
        while (cin.hasNext()) {  
            int nFlag = bellman_Ford();  
            if (nFlag == -1) {  
                System.out.println("YES");  
                  
            }  
            else {  
                System.out.println("NO");  
            }  
  
        }  
          
    }  
    public static void main(String[] args){  
          
        new Main().solve();  
          
        //System.out.println("输入结束");  
    }  
      
    class Edge{  
        public int a;  
        public int b;  
        public double rate;  
        public double commission;  
          
          
    }  
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值