tomcat启动报错解决

tomcat启动报错,具体报错信息如下:
Unable to complete the scan for annotations for web application [/Ftrans] due to a StackOverflowError. Possible root causes include a too low setting for -Xss and illegal cyclic inheritance dependencies. The class hierarchy being processed was [org.jaxen.util.AncestorAxisIterator->org.jaxen.util.AncestorOrSelfAxisIterator->org.jaxen.util.AncestorAxisIterator]


根据报错信息提示,好像是调整-Xss的大小,但这个并不是问题的所在,看后面的错误信息tomcat是在扫描org.jaxen.util.AncestorAxisIterator这个类的时候报错,所以解决方法有两个:


一、忽略tomcat启动时扫描jar包
tomcat8.0:
打开在tomcat的conf目录里面catalina.properties的文件,
tomcat.util.scan.StandardJarScanFilter.jarsToSkip=\
改为tomcat.util.scan.DefaultJarScanner.jarsToSkip=\,*


tomcat8.5:
打开在tomcat的conf目录里面catalina.properties的文件,
tomcat.util.scan.StandardJarScanFilter.jarsToSkip=\
改为tomcat.util.scan.StandardJarScanFilter.jarsToSkip=\,*


二、更新jar包
更好的解决方案是更新jar包,更新Jaxen-1.1.6和dom4j-1.6.1两个jar包

没有更多推荐了,返回首页