You can Solve a Geometry Problem too

You can Solve a Geometry Problem too

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7411    Accepted Submission(s): 3612


Problem Description
Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point. 
 

Input
Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending. 
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the number of intersections, and one line one case.
 

Sample Input
  
  
2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0
 

Sample Output
  
  
1 3
方法一:如果两线段相交,则两线段必然相互跨立对方。若P1P2跨立Q1Q2 ,则矢量 ( P1 - Q1 ) 和( P2 - Q1 )位于矢量( Q2 - Q1 ) 的两侧,即( P1 - Q1 ) × ( Q2 - Q1 ) * ( P2 - Q1 ) × ( Q2 - Q1 ) < 0。上式可改写成( P1 - Q1 ) × ( Q2 - Q1 ) * ( Q2 - Q1 ) × ( P2 - Q1 ) > 0。当 ( P1 - Q1 ) × ( Q2 - Q1 ) = 0 时,说明 ( P1 - Q1 ) 和 ( Q2 - Q1 )共线,但是因为已经通过快速排斥试验,所以 P1 一定在线段 Q1Q2上;同理,( Q2 - Q1 ) ×(P2 - Q1 ) = 0 说明 P2 一定在线段 Q1Q2上。所以判断P1P2跨立Q1Q2的依据是:( P1 - Q1 ) × ( Q2 - Q1 ) * ( Q2 - Q1 ) × ( P2 - Q1 ) >= 0。同理判断Q1Q2跨立P1P2的依据是:( Q1 - P1 ) × ( P2 - P1 ) * ( P2 - P1 ) × ( Q2 - P1 ) >= 0。
<span style="font-size:18px;"><span style="color:#33cc00;">#include <iostream>
#include<stdio.h>
#include<math.h>
#include<stdlib.h>
#include<string.h>

using namespace std;

struct point
{
    double x1,y1,x2,y2;
}s[1001];

int judge(point a,point b)
{
    double x=((a.x1-b.x1)*(b.y2-b.y1))-((a.y1-b.y1)*(b.x2-b.x1));
    double y=((b.x2-b.x1)*(a.y2-b.y1))-((b.y2-b.y1)*(a.x2-b.x1));
    //printf("%lf %lf\n",x,y);
    if((x*y)>=0)
        return 1;
    return 0;
}
int main()
{
    int n,i,j;
    int num;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0) break;
        for(i=0;i<n;i++)
        {
        scanf("%lf%lf%lf%lf",&s[i].x1,&s[i].y1,&s[i].x2,&s[i].y2);
        }
        num=0;
        for(i=0;i<n-1;i++)
        {
            for(j=i+1;j<n;j++)
            {
             if(judge(s[i],s[j])&&judge(s[j],s[i]))
                num++;
            }
        }
        printf("%d\n",num);
    }
    return 0;
}
</span><span style="color:#cc33cc;">方法二:直接套用摸板</span><span style="color:#33cc00;">
</span></span><span style="color: rgb(51, 204, 0);"></span><pre name="code" class="cpp"><span style="font-size:18px;">#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<iostream>
#define eps 1e-8
#define zero(x) (((x)>0?(x):-(x))<eps)

using namespace std;

struct point
{
    double x,y;
};

struct line
{
    point a,b;
} s[10001];


//计算cross product (P1 - P0) * (P2 - P0) 
double xmult(point p1,point p2,point p0)
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
}


//判断点是否在线段上,包括端点
int dot_online_in(point p,line l)
{
    return zero(xmult(p,l.a,l.b))&&(l.a.x-p.x)*(l.b.x-p.x)<eps&&(l.a.y-p.y)*(l.b.y-p.y)<eps;
}


//判断三点共线
int dots_inline(point p1,point p2,point p3)
{
    return zero(xmult(p1,p2,p3));
}


//判断两点在线段同侧,点在线段上返回0
int same_side(point p1,point p2,line l)
{
    return xmult(l.a,p1,l.b)*xmult(l.a,p2,l.b)>eps;
}


//判断两线段相交,包括端点和部分重合!!!
int intersect_in(line u,line v)
{
    if (!dots_inline(u.a,u.b,v.a)||!dots_inline(u.a,u.b,v.b))
    {
        return !same_side(u.a,u.b,v)&&!same_side(v.a,v.b,u);
    }
    return dot_online_in(u.a,v)||dot_online_in(u.b,v)||dot_online_in(v.a,u)||dot_online_in(v.b,u);
}

int main()
{
    int n,m;
    int i,j;
    while(scanf("%d",&n)!=EOF)
    {
        if(n == 0)
        {
            break;
        }
        int count = 0;
        for(i=0; i<n; i++)
        {
            scanf("%lf%lf%lf%lf",&s[i].a.x,&s[i].a.y,&s[i].b.x,&s[i].b.y);
        }
        for(i=0; i<n; i++)
        {
            for(j=i+1; j<n; j++)
            {
                int pp = 0;
                pp = intersect_in(s[i],s[j]);
                if(pp == 1)
                {
                    count++;
                }
            }
        }
        printf("%d\n",count);
    }
    return 0;
}</span>










 
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值