Power Network

Power Network
Time Limit: 2000MS
Memory Limit: 32768K
Total Submissions: 23147
Accepted: 12120

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount 0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

题意是给你四个数:n,np,nc,m,n代表有多少点,np代表发电站的数目,nc代表用户的数目,m代表输电线路的条数。
接下来输入m组数据,两点的坐标及距离,再输入np个数,代表发电站的发电量,再输入nc个数,代表用户最大的用电量。
在输入的时候,一定要特别注意空格问题!!!

<span style="font-size:18px;">#include <iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<queue>
using namespace std;
int flow[110][110];//记录流量
int liu[110];//记录可以流过去的量
int vis[110];
int father[110];//记录上一状态
int max_flow;
void Edmondes_Karp(int s,int t)
{
    max_flow=0;
    queue<int >p;
    int x,y,i,j;
    while(1)
    {
        memset(vis,0,sizeof(vis));
        memset(liu,0,sizeof(liu));
        liu[s]=100000000;//源点的流入量置为正无穷
        p.push(s);//将源点压入队列
        while(!p.empty())
        {
            x=p.front();
            p.pop();
            for(i=0; i<=t; i++)
            {
                if(vis[i]==0&&flow[x][i]>0)
                {
                    vis[i]=1;
                    father[i]=x;//将上一点保存下来
                    p.push(i);
                    liu[i]=min(liu[x],flow[x][i]);//以最小的流量为准
                }

            }
        }
        if(liu[t]==0)//证明没有其它的增广路可达
            break;
        for(j=t; j!=s; j=father[j])
        {
            flow[father[j]][j]-=liu[t];//正向更新
            flow[j][father[j]]+=liu[t];//反向更新(刚开始时为0)
        }
        max_flow+=liu[t];//将每一次的流量加起来
    }

}
int main()
{
    int n,np,nc,m,i,j;
    int a,b,c,d,e,f,g;
    while(scanf("%d%d%d%d ",&n,&np,&nc,&m)!=EOF)
    {
        max_flow=0;
        memset(flow,0,sizeof(flow));
        for(i=0;i<m;i++)
        {
            scanf("(%d,%d)%d ",&a,&b,&c);
            flow[a+1][b+1]+=c;
        }
        for(i=0;i<np;i++)
        {
            scanf("(%d)%d ",&d,&e);
            flow[0][d+1]+=e;
        }
        for(i=0;i<nc;i++)
        {
            scanf("(%d)%d ",&f,&g);

            flow[f+1][n+1]+=g;
        }

        Edmondes_Karp(0,n+1);//用一个更大的范围来查找
        printf("%d\n",max_flow);
    }
    return 0;
}










</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值