整理音乐

                                                                           整理音乐

 题目描述                                                                          

请用链表完成下面题目要求。
xiaobai 很喜欢音乐,几年来一直在收集好听的专辑。他有个习惯,每次在听完一首音乐后会给这首音乐打分,而且会隔一段时间给打好分的音乐排一个名次。今天 xiaobai 打开自己的音乐文件夹,发现有很多不同时期打过分的排好序的子音乐文件夹,他想把这些音乐放到一块,组成一个分数有序的序列。由于音乐文件很多,而文件里音乐的数目也是不确定的,怎么帮帮 xiaobai 完成这件工作呢?
   

输入

输入数据第一行为一个整数n(n<1000),代表文件夹的数量。接下来是n个文件夹的信息,每个文件夹信息的第一行是一个数字m,代表这个文件夹里有m首歌,后面m行每行一个歌曲名、分数,之间用空格分开。

输出

输出一行,为所有音乐组成的一个序列,音乐只输出名字。

如果音乐分数相同则按照音乐名字典序进行排序。

示例输入

34aaa 60aab 50aac 40aad 302kkk 60kkd 593qow 70qwe 60qqw 20

示例输出

qow aaa kkk qwe kkd aab aac aad qqw

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
using namespace std;
struct node
{
    int data;
    char str[30];
    node *next;
};
struct node*creat(int n)
{
    struct node*head,*p,*tail;
    int i;
    head=(struct node*)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    for(i=0; i<n; i++)
    {
        p=(struct node*)malloc(sizeof(struct node));
        scanf("%s %d",p->str,&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return (head);
}
struct node*merger(struct node*head1,struct node*head2)
{
    struct node *p1,*p2,*tail;
    p1=head1->next;
    p2=head2->next;
    tail=head1;
    free(head2);
    while(p1&&p2)
    {
        if(p1->data>p2->data)
        {
            tail->next=p1;
            tail=p1;
            p1=p1->next;
        }
        else if(p1->data<p2->data)
        {
            tail->next=p2;
            tail=p2;
            p2=p2->next;
        }
        else
        {
            if(strcmp(p1->str,p2->str)<0)
            {
                tail->next=p1;
                tail=p1;
                p1=p1->next;
            }
            else
            {
                tail->next=p2;
                tail=p2;
                p2=p2->next;
            }
        }
    }
    if(p1)
        tail->next=p1;
    else
        tail->next=p2;
    return head1;
}
int main()
{
    int n,m,i;
    struct node *head1,*head2,*p;
    cin>>n>>m;
    head1=creat(m);
    for( i=2; i<=n; i++)
    {
        cin>>m;
        head2=creat(m);
        head1=merger(head1,head2);
    }
    for(p=head1->next; p->next!=NULL; p=p->next)
    {
        cout<<p->str<<" ";
    }
    cout<<p->str<<endl;
}















评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值