用字符串模拟实现幂的精确计算

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

我的计算方法是用字符串模拟人的计算过程,可以达到很高的精度,但是效率较低。此外代码中有很多可以优化的地方,例如中间计算过程不需要ANSII码与真实数字之间的转换,减少内存复制,优化重复计算。

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;

const unsigned char ANSII_CHAR_0 = '0';
inline int AnsiiToNumber(char c) {
	return c - ANSII_CHAR_0;
}
inline char NumberToAnsii(unsigned char n) {
	return n + ANSII_CHAR_0;
}

string MultiplyOneBit(const string &base, unsigned int number) {
	if (number == 0)
		return "0";
	if (number == 1)
		return base;

	string result;
	result.resize(base.length() + 1);
	unsigned int carryBit = 0; //进位
	unsigned int oneBit; //当前位
	for (int i = base.length() - 1, j = base.length(); i >= 0; i--,j--) 	{
		oneBit = number * AnsiiToNumber(base[i]);
		oneBit += carryBit;
		result[j] = NumberToAnsii(oneBit % 10);
		carryBit = oneBit / 10;
	}
	if (carryBit == 0) {
		return result.substr(1);
	}
	else {
		result[0] = NumberToAnsii(carryBit);
		return result;
	}
}

//第一个数与第二个数左移leftbits位的和
string ShiftAdd(const string &first, const string& second, unsigned int leftbits) {
	string result;
	result.resize(max(first.length(),second.length() + leftbits) + 1);
	int vindex = result.size() - 1;
	int findex = first.length() - 1;
	int sindex = second.length() - 1;
	for (unsigned int i = 0; i < leftbits; i++) {
		result[vindex--] = first[findex--];
	}
	unsigned int carryBit = 0;
	unsigned int oneBit;
	while (findex >= 0 && sindex >= 0) {
		oneBit = AnsiiToNumber(first[findex--]) + AnsiiToNumber(second[sindex--]) + carryBit;
		result[vindex--] = NumberToAnsii(oneBit % 10);
		carryBit = oneBit / 10;
	}
	while (findex >= 0) {
		oneBit = AnsiiToNumber(first[findex--]) + carryBit;
		result[vindex--] = NumberToAnsii(oneBit % 10);
		carryBit = oneBit / 10;
	}
	while (sindex >= 0) {
		oneBit = AnsiiToNumber(second[sindex--]) + carryBit;
		result[vindex--] = NumberToAnsii(oneBit % 10);
		carryBit = oneBit / 10;
	}
	if (carryBit == 0) {
		return result.substr(1);
	}
	else {
		result[0] = NumberToAnsii(carryBit);
		return result;
	}
}

//两个整数相乘
string IntMultiply(const string &multiplier, const string& multiplicand) {
	string result("0");
	vector<string> base10(10); //为计算方便把乘数的0-9倍计算出来
	for (int i = 0; i < 10; i++) {
		base10[i] = MultiplyOneBit(multiplier, i);
	}
	for (int i = multiplicand.length() - 1, j = 0; i >= 0; i--, j++) {
		result = ShiftAdd(result, base10[AnsiiToNumber(multiplicand[i])], j);
	}
	return result;
}

//计算整数的幂
string IntPower(const string &base, unsigned int exponent) {
	string result("1");
	for (unsigned int i = 0; i < exponent; i++) {
		result = IntMultiply(result, base);
	}
	return result;
}

//计算浮点数的幂,先求出小数的位数,转换成求整数的幂,再将结果加上小数点
string FloatPower(string &base, unsigned int exponent) {
	int i;
	unsigned int npoint; //小数点后的位数
	string::size_type pos = base.find('.');
	if (pos != string::npos) {
		base.erase(pos,1); ///去掉小数点

		///消掉小数点后多余的0,例如1.0100
		i = base.length() - 1;
		while (i >= pos && base[i] == ANSII_CHAR_0) {
			i--;
		}
		if (i != base.length() - 1) {
			base = base.substr(0, i + 1);
		}
		npoint = i + 1 - pos;
	}
	else {
		npoint = 0;
	}

	//消掉前面的0,例如0123,0.123,0.0123
	i = 0;
	while (base[i] == ANSII_CHAR_0) {
		i++;
	}
	if (i) {
		base = base.substr(i);
	}

	string result = IntPower(base, exponent);
	if (npoint != 0) {
		if (result.length() < npoint*exponent){
			result = string(npoint*exponent - result.length(), ANSII_CHAR_0) + result;
		}
		result.insert(result.length() - npoint*exponent,".");
	}
	return result;
}

int main()
{
	string base;
	unsigned int exponent;
	while (cin >> base >> exponent) {
		cout << FloatPower(base, exponent) << endl;
	}
	return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 输入说明 The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9. 输出说明 The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer. 输入样例 95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12 输出样例 548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201 小提示 If you don't know how to determine wheather encounted the end of input: s is a string and n is an integer C++ while(cin>>s>>n) { ... } c while(scanf("%s%d",s,&n)==2) //to see if the scanf read in as many items as you want /*while(scanf(%s%d",s,&n)!=EOF) //this also work */ { ... } 来源 East Central North America 1988 北大OJ平台(代理

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值