hdu 1856 More is better(find函数的递归实现比while循环快7.8倍)

传送门:1856

http://blog.csdn.net/LYHVOYAGE/article/details/8981431(参考一下这个人的)

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
 
 
41 23 45 61 641 23 45 67 8
 
Sample Output
 
 
42
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result.In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

题目大意:

王老师要找一些男生帮助他完成一项工程。要求最后挑选出的男生之间都是朋友关系,可以说直接的,也可以是间接地。问最多可以挑选出几个男生(最少挑一个)。

         这是一个有关并查集的题目。只不过不是求有几个集合,而是求每个集合中元素的个数,进而求出个数的最大值。和求集合个数的方法差不多,只需要在合并两个集合时处理一下,让这两个集合的元素个数也合并一下就行了。接下来只需要找出最大值即可。要注意的一个地方就是:当n=0时,要输出1。

          

 查找函数有两种实现 在上一章 畅通工程中,用的是 循环实现的

int Find(int x) 
{
	while(father[x]!=x)
	 x=father[x];
	 
	return x;
 } 

还有一种 递归实现

int find(int x)
{
	if(x!=father[x])
	{
		father[x]=find(father[x]);
		x=father[x];
	}
	return father[x];
} 

在这道题的测试中,用循环实现find 超时 用递归 383ms

#include<iostream>
#include<cstdio>
#define N 10000005
using namespace std;
int father[N];
int num[N];
void Init()//初始化 
{
	int i;
	for(i=1;i<=N;i++)
	{
		father[i]=i;
		num[i]=1;	
	}
	
}

int find(int x)
{
	if(x!=father[x])
	{
		father[x]=find(father[x]);
		x=father[x];
	}
	return father[x];
} 

void merge(int a,int b)
{
	int temp_a=find(a);
	int temp_b=find(b);
	if(temp_a!=temp_b)
	{
		father[temp_a]=temp_b;
		num[temp_b]+=num[temp_a];
	}
}

int main()
{
	int n,a,b,i,sum,max;
	
	while(~scanf("%d",&n))
	{
		if(n==0)
		{
			 printf("1\n"); //cout<<"1"<<endl;
			continue;
		}
		max=0;
		Init();
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&a,&b);//cin>>a>>b;
			if(a>max)
				max=a;
			if(b>max)
				max=b;
			merge(a,b);
		}
		int Max=0;
		for(int i=1;i<=max;i++)
		 if(num[i]>Max)
		 	Max=num[i];
		printf("%d\n",Max);//cout<<Max<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值