poj_2478

新技能get:筛选求欧拉函数

解题思路受ACShiryu's Blog  http://www.cnblogs.com/ACShiryu/archive/2011/08/07/poj2478.html的启发


Farey Sequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11753 Accepted: 4578

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9


#include <iostream>
#include <fstream>
#include <cmath>
using namespace std;
int phi[1000006];
/*int phi(int n)
{
    int m=(int)sqrt(n+0.5);
    int ans=n;
    for(int i=2;i<=m;i++)
        if(n%i==0)//找素因子
        {
            ans=ans/i*(i-1);
            while(n%i==0)n/=i;//除尽
        }
    if(n>1)ans=ans/n*(n-1);
    return ans;
}*/

int main()
{
    //ifstream cin("in.txt");
     int i,j;
     for ( i = 2 ; i <= 1000000 ; i ++ )
    {//筛选求phi
        if ( ! phi [i] )
        {
            for ( j = i ; j <= 1000000 ; j += i )
            {
                if ( ! phi [j] )
                    phi [j ] = j ;
                phi [j] = phi [j] / i * ( i - 1 ) ;
            }
        }
    }
    int n;
    while(cin>>n&&n)
    {
        int i;
        long long s=0;//一开始这里用的是int,总是wa, 
                      //改成long long就ac了
        for(i=2;i<=n;i++)
        s+=phi[i];
        cout<<s<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值