zoj_2165

There is a rectangular room, covered with square tiles. Each tile iscolored either red or black. A man is standing on a black tile.From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.


Input

The input consists of multiple data sets. A data set starts with a line containing two positive integersW and H; W and H are the numbers of tiles in thex- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of whichincludes W characters. Each character represents the color of atile as follows.

  • '.' - a black tile
  • '#' - a red tile
  • '@' - a man on a black tile(appears exactly once in a data set)


Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).


Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0


Sample Output

45
59
6
13




//问题分析:1.首先,要开一个20*20的数组以容纳所有点格上的状态
//又,要把@找出来,将其坐标放在
//要再开一个bool zt[20][20]来保存点格是否被走过
//用int sum保存以走过的格数,并作为bfs函数的返回值
//注意啊,要memset zt
#include <iostream>
#include"string.h"


using namespace std;
int w,h,sum=1;
int tempw,temph;
int i,j;
char gezi[20][20];
bool zt[20][20];
struct p
{
int pw;
int ph;
};
p pos[400];
p pmove[4]={{0,1},{0,-1},{-1,0},{1,0}};


///
int bfs()
{
//步骤二
sum=0;
memset(zt,false,sizeof(zt));
int e,f;e=f=0;
p s,t;
    for(i=0;i<=w-1;i++)
    {
        for(j=0;j<=h-1;j++)
        {
            if(gezi[i][j]=='@')pos[e].pw=i,pos[e++].ph=j,zt[i][j]=true,sum++;
        }
    }
//步骤二完成
while(e>f)
{
    s=pos[f++];
    for(i=0;i<=3;i++)
    {
        t.ph=s.ph+pmove[i].ph;
        t.pw=s.pw+pmove[i].pw;
        if(gezi[t.pw][t.ph]=='#')continue;
        if(t.ph<0||t.ph>h-1||t.pw<0||t.pw>w-1)continue;
        if(zt[t.pw][t.ph])continue;
        zt[t.pw][t.ph]=true;
        pos[e++]=t;
        sum++;
    }
}
return sum;
}




//
int main()
{
//步骤一
    while (cin>>w>>h&&w!=0&&h!=0)
    {




    for(j=0;j<=h-1;j++)
    {
        for(i=0;i<=w-1;i++)
        {
            cin>>gezi[i][j];
        }
    }
  
    cout<<bfs()<<endl;
//步骤一完成
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值