浙工大姗姗杯round1 F - Rikka with Parenthesis II

Rikka with Parenthesis II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1545    Accepted Submission(s): 686


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Correct parentheses sequences can be defined recursively as follows:
1.The empty string "" is a correct sequence.
2.If "X" and "Y" are correct sequences, then "XY" (the concatenation of X and Y) is a correct sequence.
3.If "X" is a correct sequence, then "(X)" is a correct sequence.
Each correct parentheses sequence can be derived using the above rules.
Examples of correct parentheses sequences include "", "()", "()()()", "(()())", and "(((())))".

Now Yuta has a parentheses sequence  S , and he wants Rikka to choose two different position  i,j  and swap  Si,Sj

Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100

For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.
 

Output
For each testcase, print "Yes" or "No" in a line.
 

Sample Input
  
  
3 4 ())( 4 ()() 6 )))(((
 

Sample Output
  
  
Yes Yes No
Hint
For the second sample input, Rikka can choose (1,3) or (2,4) to swap. But do nothing is not allowed.

题意:()(())这样左右配对的括号算好的,)(这样算不好的,如果交换一次能变成好的括号,就输出yes,不然就no,必须交换一次;

思路:参考MOOC数据结构堆栈对等式优先度的写法,模板题。坑点,因为必须交换一次,所以()是错的,输出no

#include <bits/stdc++.h>

using namespace std;

int main()
{
    stack<char> s;
    int tt;
    cin >> tt;
    int n;
    string p;
    while(tt--)
    {
        cin >> n;
        cin >> p;
        for(int i = 0; i < n; i++)
        {
            if(p[i] == '(')
                s.push(p[i]);
            else {
                if(s.size() > 0 && s.top() == '(')
                    s.pop();
                else {
                    s.push(p[i]);
                }
            }
        }
        if( n%2 == 1||n < 2 || s.size() > 4)
            cout << "No" << endl;
        else if(n == 2 && s.size() == 0) cout << "No" << endl;
        else cout << "Yes" << endl;
        while(s.size())
            s.pop();
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值