3835. 计算三角形的周长

3835. 计算三角形的周长


Description


在平面直角坐标系中,给出三角形三个顶点的坐标,求三角形的周长.


Input


第一行是一个整数T,表示总共有T组数据.


接下来的T行,每行有6个实数x1, y1, x2, y2, x3, y3,表示三角形三个顶点的坐标.


Output


每行输出一个三角形的周长,小数点后保留5位数字.


Sample Input


2
0 0 0 3 4 0
1.2 5.5 -1.0 -4.7 3.2 -0.8
Sample Output


12.00000

22.77589


// source code of submission 967568, Zhongshan University Online Judge System
#include <iostream>
#include <cmath>
#include <iomanip>
using namespace std;

int main()
{
    int n;
    double x1,y1,x2,y2,x3,y3,s;
    cin >> n;
    while(n--)
    {
        cin >> x1 >> y1 >> x2 >> y2 >> x3 >> y3;
        s=sqrt((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1))+sqrt((x3-x1)*(x3-x1)+(y3-y1)*(y3-y1))+sqrt((x2-x3)*(x2-x3)+(y2-y3)*(y2-y3));
        cout << fixed << setprecision(5) << s << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值