1500. Prime Gap

1500. Prime Gap

Description

The sequence of n ? 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers p and p + n is called a prime gap of length n. For example, 24, 25, 26, 27, 28 between 23 and 29 is a prime gap of length 6.

Your mission is to write a program to calculate, for a given positive integer k, the length of the prime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains k.

Input

The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated by a line containing a single zero.

Output

The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or 0 otherwise. No other characters should occur in the output.

Sample Input

10
11
27
2
492170
0

Sample Output

4
0
6
0
114

Problem Source

Tokyo 2007

// source code of submission 966492, Zhongshan University Online Judge System
#include <iostream>
#include <cmath>
using namespace std;

int prime[100001];
bool ispri(int n)
{
     for(int i=2;i<=sqrt(double(n));i++)
        if(n%i==0)
            return false;
     return true;
}
void getprime()
{
     int l=0;
     for(int i=2;i<=1299709;i++)
        if(ispri(i))
           prime[l++]=i;
}
int main()
{
    getprime();
    int k;
    while(cin>>k&&k)
    {
         int i=0;
         for(;i<100000;i++)
            if(prime[i]>=k)
               break;
         if(prime[i]==k)
            cout<<0<<endl;
         else
            cout<<prime[i]-prime[i-1]<<endl;           
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值