1159. Sum

1159. Sum

Description

Given several positive integers, calculate the sum of them.

Input

There are several test cases, one line for each case. For each line, the first number, N (N<=100000), is the number of positive numbers and then N positive numbers followed. The sum will not exceed 10100.

Output

Output each sum in a single line without leading zeros.

Sample Input

3 1 2 3
1 123
2 1111111111111111111111111111111111 1111111111111111111111111111111111

Sample Output

6
123
2222222222222222222222222222222222

Problem Source

ZSUACM Team Member




#include <iostream>
#include <string>
#include <cstring>
using namespace std;

int main()
{
	int t;
	while(cin>>t)
	{
		int a[101]={0},max=0;
		string str;
		for(int i=1;i<=t;i++)
		{
			cin>>str;
			if(str.length()>max) max=str.length();
			for(int j=str.length()-1;j>=0;j--)
			{
				a[str.length()-1-j]+=(str[j]-'0');
			}
			for(int k=0;k<str.length();k++)
			{
				if(a[k]>=10)
				{
					a[k+1]++;
					a[k]%=10;
				}
			}
		}
		if(a[max]>0) cout<<a[max];
		for(int j=max-1;j>=0;j--)
				cout<<a[j];
		cout<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值