PAT A1096 Consecutive Factors (20)

总结:

1.读懂题:写代码之前想好大致思路,哪个变量用来干什么自己要搞清楚

2.不要急躁,写不出来仔细想,别自暴自弃

1096 Consecutive Factors (20)(20 分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2^31^).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

 

代码:

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    int m;
    cin >> m;
    int k = sqrt(1.0*m); int sum = 1;
   //如果是质数,就只有一个因数
    int totalc = 1; int maxc = 0; int first = 0; int last = 0;
    for (int i = 2; i <= k; i++)
    {
        sum = 1;
        for (int j = i; j <= k+1; j++)
        {
            sum *= j;
            if (m%sum != 0)
                break;
            if (j - i+1 > maxc)
            {
                first = i; last = j; maxc = j - first + 1;
            }
        }
    }
    
    if (first== 0){
        printf("1\n"); printf("%d",m);
    }
    else {
        printf("%d\n",maxc);
        for (int i =first; i <=last; i++)
        {
            printf("%d",i);
            if (i !=last)printf("*");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值