POJ Problem 1423 Big Number 【stirling公式】

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27709 Accepted: 8837

Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= m <= 10^7 on each line.

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2
10
20

Sample Output

7
19

Source

这道题考察stirling公式。当n充分大时,n!与sqrt(2πn * pow(n/e,n))十分接近。利用此公式,可以对阶乘有更好的估算。
,对于这道题,两边同时取以十为底的对数后,n!的位数就等于右边式子加上一。
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <stack>
#include <iostream>
#define MAX_N   100005
#define MAX(a, b) (a > b)? a: b
#define MIN(a, b) (a < b)? a: b
using namespace std;
const double e = 2.71828182845904523536;
const double PI = 3.141592653589793238;

double strling(int n) {
    return 0.5*log10(2*PI*n) + n*log10(n/e);
}
int main() {
    int t, m;
    scanf("%d", &t);
    while (t--) {
        scanf("%d", &m);
        printf("%d\n", (int)strling(m) + 1);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值