Rikka with Subset(HDU 6092)

Rikka with Subset

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 845    Accepted Submission(s): 412


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has  n  positive  A1An  and their sum is  m . Then for each subset  S  of  A , Yuta calculates the sum of  S

Now, Yuta has got  2n  numbers between  [0,m] . For each  i[0,m] , he counts the number of  i s he got as  Bi .

Yuta shows Rikka the array  Bi  and he wants Rikka to restore  A1An .

It is too difficult for Rikka. Can you help her?  
 

Input
The first line contains a number  t(1t70) , the number of the testcases. 

For each testcase, the first line contains two numbers  n,m(1n50,1m104) .

The second line contains  m+1  numbers  B0Bm(0Bi2n) .
 

Output
For each testcase, print a single line with  n  numbers  A1An .

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.
 

Sample Input
  
  
2 2 3 1 1 1 1 3 3 1 3 3 1
 

Sample Output
  
  
1 2 1 1 1
Hint
In the first sample, $A$ is $[1,2]$. $A$ has four subsets $[],[1],[2],[1,2]$ and the sums of each subset are $0,1,2,3$. So $B=[1,1,1,1]$


 //题意:b[i]代表的是a数组里一个或几个元素的和等于 i 的个数,现在告诉你a数组里有几个元素,给你b数组,要求a数组。比如,a里如果是1 1 2的话,b就是1 2 2 2 4。a里所有元素和为m。b里有m个元素,因为子集包括空集,所以b[0]恒等于1。

//思路设b中除b[0]外第一个不为0的是b[i],那么 i 必为a中元素,因为找不到比它更小的能构成它的数。

比如b[0]=1;b[1]=1;b[2]=1;b[3]=1; 那么根据b[1]=1我们可以推出a中一定有1。

然后,我们删去找出的这个元素,得到新的b数组。从小到大,b[j]=b[j]-b[j-i]; (j从i开始到m)

重复上述步骤,如果b1-bm都为0了,循环结束。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;

const int MAX = 1e4 + 100;

int n, m;
long long b[MAX];
long long num[MAX];

int main()
{
	int i;
	int T;
	scanf("%d", &T);
	while (T--)
	{
		memset(num, 0, sizeof(num));
		scanf("%d%d", &n, &m);
		for (int i = 0; i <= m; i++)
			scanf("%lld", &b[i]);
		int cnt = 0;
		while (true)
		{
			int pos;
			for (i = 1; i <= m; i++)
			{
				if (b[i] != 0)
				{
					pos = i;
					num[cnt++] = i;
					break;
				}
			}
			if (i == m + 1)
				break;
			for (i = pos; i <= m; i++)
			{
				b[i] = b[i] - b[i - pos];
			}
		}
		printf("%d", num[0]);
		for (i = 1; i < cnt; i++)
			printf(" %d", num[i]);
		printf("\n");
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值