poj 3660 (floyd)

题目

题目链接
Cow Contest
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19773 Accepted: 10979
Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1…N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5
Sample Output

2

分析

碎碎念qwq

最开始我想到的是用拓扑排序,不过迟迟没有思路,看了大佬的博客后豁然开朗awa弗洛伊德的千种套路

正文

题目让我们寻找哪些牛的排名是可以确定的
通过题中给出的案例分析,我们可以得到这样一个关系图

1
2
3
4
5

可以看到,2和5的排名是确定的,而1,4,3这三头牛,因为1和4,3的关系不明确,所以这三头牛的关系不确定。
我们又可以从这个图中知道,确定了排名的牛,与其他牛的关系都是确定的,
1,4,3都能打败2,2能打败5
1,2,3,4都能打败5
但是对于1,你只能知道1能打败2,5,但是你不知道3,4和1的关系
所以,我们可以像存图一样,把这个关系存起来
这是一个有向无环图
之后我们就可以用弗洛伊德来更新所有节点之间的关系,找出与其他节点关系确定的节点,就得出最后结果了

代码

#include <iostream>
#include <string>
#include <cstring>

#define mt(x, k) memset(x,k, sizeof(x))
using namespace std;

int main() {
    ios::sync_with_stdio(0), cin.tie(0), cout.tie(0);
    int mp[110][110], n, m, a, b;
    mt(mp, 0);
    cin >> n >> m;
    for (int i = 0; i < m; ++i) {
        cin >> a >> b;
        mp[a][b] = 1;
    }
    for (int k = 1; k <= n; ++k) {
        for (int i = 1; i <= n; ++i) {
            for (int j = 1; j <= n; ++j) {
                if (mp[i][k] && mp[k][j])mp[i][j] = 1;
            }
        }
    }
    int ans = 0, j;
    for (int i = 1; i <= n; ++i) {
        for (j = 1; j <= n; ++j) {
            if (i == j)continue;
            if (mp[i][j] == 0 && mp[j][i] == 0)break;
        }
        if (j > n)ans++;
    }
    cout << ans << '\n';
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值