Dylans loves sequence



Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 405    Accepted Submission(s): 201


Problem Description
Dylans is given  N  numbers  a[1]....a[N]

And there are  Q  questions.

Each question is like this  (L,R)

his goal is to find the “inversions” from number  L  to number  R .

more formally,his needs to find the numbers of pair( x,y ),
that  Lx,yR  and  x<y  and  a[x]>a[y]
 

Input
In the first line there is two numbers  N  and  Q .

Then in the second line there are  N  numbers: a[1]..a[N]

In the next  Q  lines,there are two numbers  L,R  in each line.

N1000,Q100000,LR,1a[i]2311
 

Output
For each query,print the numbers of "inversions”
 

Sample Input
  
  
3 2 3 2 1 1 2 1 3
 

Sample Output
  
  
1 3
Hint
You shouldn't print any space in each end of the line in the hack data.
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5275  5274  5272  5271  5270 



#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<stack>
#include<queue>
using namespace std;
int dp[1010][1010];
int figure[1010];
int cont;
int main()
{
    int m,n;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&figure[i]);
        }
        for(int i=2;i<=n;i++)       //从1到2.3.4.。。。。n的逆序数;
        {
            dp[1][i]=dp[1][i-1];
            for(int j=1;j<i;j++)
            {
                if(figure[j]>figure[i])
                dp[1][i]++;
            }
        }
        for(int i=2;i<n;i++)                                       由1到n推i到j;
        {
            cont=figure[i-1]>figure[i]?1:0;
            for(int j=i+1;j<=n;j++)
            {
                if(figure[i-1]>figure[j])cont++;
                dp[i][j]=dp[i-1][j]-cont;
            }
        }
        int u,v;
        while(m--)
        {
            scanf("%d%d",&u,&v);
            printf("%d\n",dp[u][v]);
        }

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值