POJ3274----Gold Balanced Lineup(黄金平衡)

Gold Balanced Lineup
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13249 Accepted: 3878

Description

Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list of only K different features (1 ≤ K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.

FJ has even devised a concise way to describe each cow in terms of its "feature ID", a single K-bit integer whose binary representation tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits feature i.

Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous range of cows i..j is balanced if each of the K possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.

Input

Line 1: Two space-separated integers, N and K.
Lines 2.. N+1: Line i+1 contains a single K-bit integer specifying the features present in cow i. The least-significant bit of this integer is 1 if the cow exhibits feature #1, and the most-significant bit is 1 if the cow exhibits feature # K.

Output

Line 1: A single integer giving the size of the largest contiguous balanced group of cows.

Sample Input

7 3
7
6
7
2
1
4
2

Sample Output

4

Hint

In the range from cow #3 to cow #6 (of size 4), each feature appears in exactly 2 cows in this range


#include <iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int N=99997;
int sum[N+10][31];
int feature[N+10][31];
int c[N+10][31];
struct node
{
    int pos;
    int next;
} T[N<<1];
int top;
int ans;
int n,k;
int head[N];
bool allsame(int x)
{
    for(int i=1;i<k;i++)
    {
        if(sum[x][i]!=sum[x][i-1])
            return 0;
    }
    return 1;
}
bool comp(int x1,int x2)
{
    for(int i=0; i<k; i++)
    {
        if(sum[x1][i]!=sum[x2][i])
            return 0;
    }
    return 1;
}
int getHash(int x)
{
    int g=0;
    for(int i=1; i<k; i++)
    {
        g+=sum[x][i]*(i+1);
    }

    return (g&0x7fffff)%N;
}
void Searchash(int x)
{
    int d=getHash(x);
    int  p=head[d];
    while(p!=-1)
    {
        if(comp(T[p].pos,x))
        {
            ans=max(x-T[p].pos,ans);
            return;
        }
        p=T[p].next;
    }
    T[top].pos=x;
    T[top].next=head[d];
    head[d]=top++;
}
int main()
{
    int x;
    int i,j;
    while(~scanf("%d%d",&n,&k))
    {

        memset(head,-1,sizeof(head));
        top=0;
        ans=0;
        memset(sum,0,sizeof(sum));
        for(i=0; i<n; i++)
        {
            scanf("%d",&x);
            for(j=0; j<k; j++)
            {
                sum[i][j]=(x&1);
                x>>=1;

            }

        }
        for(i=1; i<n; i++)
        {
            for(j=0; j<k; j++)
                sum[i][j]+=sum[i-1][j];
        }
        for (i = n - 1; i >= 0;i--)
        {
            if (allsame(i))
            {
                ans = i + 1;
                printf("%d\n",ans);
                break;
            }
        }
        for(i=0; i<n; i++)
        {
            for(j=1; j<k; j++)
            {
                sum[i][j]=sum[i][j]-sum[i][0];
            }
            sum[i][0]=0;
        }
        for( i=0; i<n; i++)
        {
            Searchash(i);
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值