POJ-3274 Gold Balanced Lineup 解题报告

Description

Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list of only K different features (1 ≤ K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.

FJ has even devised a concise way to describe each cow in terms of its "feature ID", a single K-bit integer whose binary representation tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits feature i.

Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous range of cows i..j is balanced if each of theK possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.

Input

Line 1: Two space-separated integers,  N and  K
Lines 2.. N+1: Line  i+1 contains a single  K-bit integer specifying the features present in cow  i. The least-significant bit of this integer is 1 if the cow exhibits feature #1, and the most-significant bit is 1 if the cow exhibits feature # K.

Output

Line 1: A single integer giving the size of the largest contiguous balanced group of cows.

Sample Input

7 3
7
6
7
2
1
4
2

Sample Output

4

Hint

In the range from cow #3 to cow #6 (of size 4), each feature appears in exactly 2 cows in this range

        题目链接:http://poj.org/problem?id=3274
       解法类型:hash
       解题思路:一道hash题啊,找key啊。当时做的时候觉得hash不好用,但它就是可以用hash优化,参考了一下别人的算法,让我对hash有了更深的领悟。首先把数转化成二进制矩阵,然后用一个数组s[i][j]来储存第j列的前i个数二进制的和,再用一个数组c[i][j]=s[i][j]-s[i][0],这样,只要某两行c[i][j]相同,那么这两行就可以算成一个contiguous balanced group。key就出来了,求和再取余或相乘再取余,随你。。~
       算法实现:
//STATUS:C++_AC_969MS_27536K
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
const int MAXN=100010,MAX_HASH=99991;
int s[MAXN][30],c[MAXN][30];
int count(int a,int b);
int k;
struct NODE     //链表写hash表
{
	struct NODE(){next=NULL;};
	int num;
	NODE *next;
}hash[MAX_HASH];
int main()
{
//	freopen("in.txt","r",stdin);
	int i,j,a,n,sumc,max;
	while(~scanf("%d%d",&n,&k))
	{
		max=0;
		memset(s,0,sizeof(s));
		memset(hash,0,sizeof(hash));
		NODE *p=(NODE*)malloc(sizeof(NODE));
		hash[0].num=0,hash[0].next=p,p->next=NULL;   //这个很重要,因为要考虑第一组的情况

		for(i=1;i<=n;i++){
		    scanf("%d",&a);
			for(j=0,sumc=0;j<k;j++){
		     	s[i][j]=s[i-1][j]+((a&(1<<j))?1:0);	   //位运算二进制

				c[i][j]=s[i][j]-s[i][0];
				sumc+=c[i][j];
			}

			int t=sumc%MAX_HASH;
			if(t<0)t=-t;
			NODE *p=&hash[t];
			for(;p->next!=NULL;p=p->next){    //搜索hash表
				int ok=count(p->num,i);
				if(ok!=-1 && ok>max)max=ok;
			}	
			NODE *q=(NODE*)malloc(sizeof(NODE));   //搜索hash表
			p->num=i;
			p->next=q;
			q->next=NULL;
		}			
		printf("%d\n",max);
	}
	return 0;
}

int count(int a,int b)      //比较是否构成contiguous balanced group
{
	int j;
	for(j=0;j<k;j++){
		if(c[a][j]!=c[b][j])return -1;
	}
	return b-a;
}

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值