POJ3252_Round Numbers

Round Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10475 Accepted: 3825


题意:一个数转换为二进制后如果0的个数>=1的个数;那么这个数就叫做Round Numbers;

求n,m间的Round Numbers的个数;

思路:  n,m之间    [0,m+1)-[0,n);


Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start.. Finish

Sample Input

2 12

Sample Output

6

Source

USACO 2006 November Silver



Source Code
Problem: 3252		User: 14110103069
Memory: 660K		Time: 16MS
Language: G++		Result: Accepted

    Source Code

    #include <iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<queue>
    #include<cmath>
    #include<stack>
    #include<cctype>
    #include<set>
    #include<map>
    #include<vector>
    #define LL long long
    #define uLL unsigned LL
    using namespace std;
    int C[35][35];
    int bit[35];
    int wei(int x)
    {
        int k=0;
        while(x)
        {
            bit[++k]=x%2;
            x>>=1;
        }
        return k;
    }
    int solve(int x)
    {
        int k=wei(x);
        int ans=0;
        for(int i=1; i<k-1; i++)                   //小于K位的个数;
        {
            for(int j=i/2+1; j<=i; j++)
                ans+=C[i][j];
        }
        int zero=0;
        int g=(k+1)/2; 
        for(int i=k-1; i>=1; i--)     
        {
            if(bit[i])                                                 //同k位的;从第二位开始为1的数开始降为零;
                for(int j=g-(zero+1); j<i; j++)
                    ans+=C[i-1][j];
            else
                zero++;
        }
        return ans;
    }
    int main()
    {
        memset(C,0,sizeof(C));
        C[0][0]=1;
        for(int i=1; i<35; i++)
        {
            C[i][0]=1;
            for(int j=1; j<=i; j++)
            {
                C[i][j]=C[i-1][j-1]+C[i-1][j];
            }
        }
        int m,n;
        while(~scanf("%d%d",&n,&m))
        {
            printf("%d\n",solve(m+1)-solve(n));
        }
        return 0;
    }



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值