Round Numbers POJ - 3252(数位dp)

Round Numbers POJ - 3252

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input
Line 1: Two space-separated integers, respectively Start and Finish.
Output
Line 1: A single integer that is the count of round numbers in the inclusive range Start.. Finish
Sample Input

2 12

Sample Output

6
题意:

判断l,r之间有多少个数字二进制形式0的个数大于等于1的个数

分析:

比较裸的数位dp

code:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
typedef long long ll;
ll dp[50][110];//dp[pos][dif+40]表示pos位置01个数差值,为了防止负数越界我们加上40
int bit[50];
ll dfs(int pos,int dif,bool lead,bool limit){//pos表示当前位置,dif表示01个数差0减1加,lead表示是否有前导零0表示有1表示无,limit表示是否有限制1表示有0表示没有
    if(pos < 0)
        return dif <= 0;//差值小于等于0说明0个数大于1
    if(!limit && lead && dp[pos][dif+40] != -1)
        return dp[pos][dif+40];
    int digit = limit ? bit[pos] : 1;
    int x;
    ll ans = 0;
    for(int i = 0; i <= digit; i++){
        if(i)
            x = dif + 1;
        else{
            if(lead)
                x = dif - 1;
            else
                x = dif;
        }
        ans += dfs(pos-1,x,lead || i,limit && i == digit);
    }
    if(!limit && lead)
        dp[pos][dif+40] = ans;
    return ans;
}
ll solve(ll n){
    int len = 0;
    while(n){
        bit[len++] = n & 1;
        n >>= 1;
    }
    return dfs(len-1,0,0,1);
}
int main(){
    ll l,r;
    memset(dp,-1,sizeof(dp));
    while(scanf("%lld%lld",&l,&r) != EOF){
        printf("%lld\n",solve(r) - solve(l-1));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值