BestCoder Round #77 (div.2)

xiaoxin juju needs help

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1124    Accepted Submission(s): 323



提示:可重集的全排列+逆元;(板子题,)
弱渣要学逆元啦!
Problem Description
As we all known, xiaoxin is a brilliant coder. He knew **palindromic** strings when he was only a six grade student at elementry school.

This summer he was working at Tencent as an intern. One day his leader came to ask xiaoxin for help. His leader gave him a string and he wanted xiaoxin to generate palindromic strings for him. Once xiaoxin generates a different palindromic string, his leader will give him a watermelon candy. The problem is how many candies xiaoxin's leader needs to buy?
 

Input
This problem has multi test cases. First line contains a single integer T(T20) which represents the number of test cases.
For each test case, there is a single line containing a string S(1length(S)1,000) .
 

Output
For each test case, print an integer which is the number of watermelon candies xiaoxin's leader needs to buy after mod 1,000,000,007 .
 

Sample Input
  
  
3 aa aabb a
 

Sample Output
  
  
1 2 1
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5654  5653  5649  5648  5647

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <vector>
#define  LL long long
using namespace std;
LL A[1010]= {1,1};
int D[26];
char s[1010];
LL MOD=1e9+7;
LL solve( LL x)
{
    LL n=MOD-2;
    LL ans=1;
    while(n)
    {
        if(n&1)
        {
            (ans*=x)%=MOD;
        }
        (x*=x)%=MOD;
        n>>=1;
    }
    return ans;
}
int main()
{
    for(LL i=2; i<1001; i++)
        (A[i]=A[i-1]*i)%=MOD;
    int t;
    cin>>t;
    while(t--)
    {
        scanf("%s",s);
        memset(D,0,sizeof(D));
        for(int i=0; s[i]; i++)
            D[s[i]-'a']++;
        int odd=0,cnt=0;
        for(int i=0;i<26; i++)
        {
            if(D[i]%2)
                odd++;
            D[i]/=2;
            cnt+=D[i];
        }
        if(odd>1)
        {
            printf("0\n");
            continue;
        }
        LL ans=A[cnt];
        for(int i=0; i<26; i++)
        {
            (ans*=(solve(A[D[i]])))%=MOD;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值