BestCoder Round #81 (div.2)

 

Matrix

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 357    Accepted Submission(s): 158


对于交换行、交换列的操作,分别记录当前状态下每一行、每一列是原始数组的哪一行、哪一列即可。

对每一行、每一列加一个数的操作,也可以两个数组分别记录。注意当交换行、列的同时,也要交换增量数组。

输出时通过索引找到原矩阵中的值,再加上行、列的增量。

复杂度O(q+mn)O(q+mn)O(q+mn)



Problem Description
There is a matrix M that has n rows and m columns (1n1000,1m1000) .Then we perform q(1q100,000) operations:

1 x y: Swap row x and row y (1x,yn) ;

2 x y: Swap column x and column y (1x,ym) ;

3 x y: Add y to all elements in row x (1xn,1y10,000) ;

4 x y: Add y to all elements in column x (1xm,1y10,000) ;
 

Input
There are multiple test cases. The first line of input contains an integer T(1T20) indicating the number of test cases. For each test case:

The first line contains three integers n , m and q .
The following n lines describe the matrix M. (1Mi,j10,000) for all (1in,1jm) .
The following q lines contains three integers a(1a4) , x and y .
 

Output
For each test case, output the matrix M after all q operations.
 

Sample Input
  
  
2 3 4 2 1 2 3 4 2 3 4 5 3 4 5 6 1 1 2 3 1 10 2 2 2 1 10 10 1 1 1 2 2 1 2
 

Sample Output
  
  
12 13 14 15 1 2 3 4 3 4 5 6 1 10 10 1
Hint
Recommand to use scanf and printf
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5674  5673  5672  5669  5668

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <algorithm>
#include <set>
#define LL long long
using namespace std;
int A[1010][1010];
int H[1010],L[1010];
int AddH[1010],AddL[1010];
int main()
{
   int n,m,q;
   int u,x,y;
   int t;
   cin>>t;
   while(t--)
   {
       scanf("%d%d%d",&n,&m,&q);
       for(int i=1;i<=n;i++)
        H[i]=i;
       for(int j=1;j<=m;j++)
        L[j]=j;
       memset(AddH,0,sizeof(AddH));
       memset(AddL,0,sizeof(AddL));
       for(int i=1;i<=n;i++)
       {
           for(int j=1;j<=m;j++)
           {
               scanf("%d",&A[i][j]);
           }
       }
       while(q--)
       {
           scanf("%d%d%d",&u,&x,&y);
           if(u==1)
           {
               swap(H[x],H[y]);
               swap(AddH[x],AddH[y]);
           }
           else if(u==2)
           {
                swap(L[x],L[y]);
               swap(AddL[x],AddL[y]);
           }
           else if(u==3)
           {
               AddH[x]+=y;
           }
           else
           {
               AddL[x]+=y;
           }
       }
       for(int i=1;i<=n;i++)
       {
           for(int j=1;j<=m;j++)
           {
               if(j!=1)
                printf(" ");
               printf("%d",A[H[i]][L[j]]+AddH[i]+AddL[j]);
           }
           printf("\n");
       }
   }

    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值