POJ——2002——Squares

Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 18697 Accepted: 7205

给出一些点,统计这些店中构成正方形的个数

利用向量已知对角线的两个顶点, 可求得构成正方形的另外两个顶点,可二分找点;

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

Source


#include <iostream>
#include <cstdio>
#include <cstring>
#include<algorithm>
using namespace std;
struct node
{
    int x,y;
    bool operator <(const node &A)const
    {
        if(x==A.x)
            return y<A.y;
        return x<A.x;
    }
    bool operator != (const node &B)const
    {
        if(x!=B.x||y!=B.y)
            return 1;
        return 0;
    }
}que[10100];
int main()
{
   int n;
   int x,y;
   int xmid,ymid;
   node now,tmp;
   while(cin>>n,n)
   {
       for(int i=0;i<n;i++)
       {
           scanf("%d%d",&que[i].x,&que[i].y);
           que[i].x<<=1;que[i].y<<=1;
       }
       sort(que,que+n);
       int ans=0;
       for(int i=0;i<n;i++)
       {
           for(int j=i+1;j<n;j++)
           {
               xmid=(que[i].x+que[j].x)/2;
               ymid=(que[i].y+que[j].y)/2;
               x=(que[i].x-que[j].x)/2;
               y=(que[i].y-que[j].y)/2;
               now.x=xmid-y;
               now.y=ymid+x;
               tmp.x=(2*xmid)-now.x;
               tmp.y=(2*ymid)-now.y;
               int cnt=lower_bound(que,que+n,now)-que;
               if(que[cnt]!=now)
                continue;
                cnt=lower_bound(que,que+n,tmp)-que;
                if(que[cnt]!=tmp)
                    continue;
                ans++;
           }
       }
       printf("%d\n",ans>>1);
   }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值