Peaceful Commission(2-sat)

Peaceful Commission

Time Limit: 10000/5000 MS (Java/Others)
Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5178 Accepted Submission(s): 1657

Problem Description

The Public Peace Commission should be legislated in Parliament of The Democratic Republic of Byteland according to The Very Important Law. Unfortunately one of the obstacles is the fact that some deputies do not get on with some others.

The Commission has to fulfill the following conditions:
1.Each party has exactly one representative in the Commission,
2.If two deputies do not like each other, they cannot both belong to the Commission.

Each party has exactly two deputies in the Parliament. All of them are numbered from 1 to 2n. Deputies with numbers 2i-1 and 2i belong to the i-th party .

Task

Write a program, which:
1.reads from the text file SPO.IN the number of parties and the pairs of deputies that are not on friendly terms,
2.decides whether it is possible to establish the Commission, and if so, proposes the list of members,
3.writes the result in the text file SPO.OUT.

Input

In the first line of the text file SPO.IN there are two non-negative integers n and m. They denote respectively: the number of parties, 1 <= n <= 8000, and the number of pairs of deputies, who do not like each other, 0 <= m <=2 0000. In each of the following m lines there is written one pair of integers a and b, 1 <= a < b <= 2n, separated by a single space. It means that the deputies a and b do not like each other.
There are multiple test cases. Process to end of file.

Output
The text file SPO.OUT should contain one word NIE (means NO in Polish), if the setting up of the Commission is impossible. In case when setting up of the Commission is possible the file SPO.OUT should contain n integers from the interval from 1 to 2n, written in the ascending order, indicating numbers of deputies who can form the Commission. Each of these numbers should be written in a separate line. If the Commission can be formed in various ways, your program may write mininum number sequence.

Sample Input
3 2
1 3
2 4
Sample Output
1
4
5

题目大意:每个国家有两个代表,每个国家必须选一个人出来参加会议。有一些限制,有些人不能同时选。输出字典序最小的方案,如果没有方案,输出nie。










解:

2-sat的板子题,大意就是两个人不能同时选就代表选了某一个就不能选另一个,那么我们就要选另一个相同国家的那个人。于是连边,dfs判选人是否合法。因为选人对后续选人是没有影响的所以可直接把选人定下来。
虽然是 n2 n 2 的,但是远远卡不满(只是给不想学高级算法找借口而已)。

其实只是来贴波板而已:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct lxy{
    int to,next;
}eg[100005];

int n,m,x,y,cnt;
int head[16005];
bool vis[16005];
queue <int> d;

int readit()
{
    int a=0;char s=getchar();
    while(s<'0'||s>'9') s=getchar();
    while(s>='0'&&s<='9'){
        a=a*10+s-'0';
        s=getchar();
    }
    return a;
}

void add(int op,int ed)
{
    eg[++cnt].next=head[op];
    eg[cnt].to=ed;
    head[op]=cnt;
}

bool dfs(int u)
{
    if(vis[u^1]==1) return false;
    vis[u]=1;d.push(u);
    for(int i=head[u];i!=-1;i=eg[i].next)
      if(vis[eg[i].to]==0)
          if(!dfs(eg[i].to))
              return false;
    return true;
}

int main()
{
    while(~scanf("%d%d",&n,&m)){
        cnt=0;
        memset(head,-1,sizeof(head));
        memset(vis,0,sizeof(vis));
        memset(eg,0,sizeof(eg));
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);x--,y--;
            add(y,x^1);
            add(x,y^1);
        }
        for(int i=0;i<2*n;i+=2)
        {
            if(vis[i]+vis[i^1]==1){
                if(i==2*n-2){
                for(int j=0;j<2*n;j+=2)
                {
                    if(vis[j]==0) printf("%d\n",j+2);
                    else printf("%d\n",j+1);
                }
            }continue;
            }
            while(!d.empty()) d.pop();

            if(!dfs(i)){
              while(!d.empty()) vis[d.front()]=0,d.pop();

              if(!dfs(i^1))
              {
                  printf("NIE\n");
                  break;
              }
            }
            if(i==2*n-2){
                for(int j=0;j<2*n;j+=2)
                {
                    if(vis[j]==0) printf("%d\n",j+2);
                    else printf("%d\n",j+1);
                }
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值