Choose the best route dijst算法

思路:一开始想着多次dijst但是超时了 后来在网上看到一个超点汇集。就是将所有开始的点都使得与0点有一条边,最好这条边的权值为0,然后从0点开始求。这就是求0点到其他点的最短路径。但是0点只与开始点相连了而且他们的权值为0,所有dijst算法求的时候就选择了最短到终点的边。

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
  
  
1 -1
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define wqd 999999999
int map[1003][1001];
int n,m,s,count;
int d[1001];
int a[1001];
bool vis[1001];
int dijst(int *d,int v0)
{

    for(int i=0;i<=n;i++)
    {
        if(i!=v0&&map[v0][i]!=0)
        {
            d[i]=map[v0][i];


        }
        else
        {
            d[i]=wqd;


        }
        vis[i]=0;
    }
    d[v0]=0;
    vis[v0]=1;
for(int j=0;j<=n;j++)
{
     int min=wqd,u;

    for(int i=0;i<=n;i++)
    {
        if(!vis[i]&&d[i]<=min)
        {
            min=d[i];
            u=i;
        }
    }
    vis[u]=1;
    for(int i=0;i<=n;i++)
    {
        if(map[u][i]!=0&&!vis[i]&&d[u]+map[u][i]<d[i])//找路径松弛一次
        {
            d[i]=d[u]+map[u][i];


        }

    }
}
}
int main()
{
    int t;
    while(~scanf("%d%d%d",&n,&m,&s))
    {   memset(map,0,sizeof(map));
        for(int i=1;i<=m;i++)
        {
            int x,y,w;
            scanf("%d%d%d",&x,&y,&w);
            if(map[x][y]==0)
            {
                map[x][y]=w;
             
            }
            else if(map[x][y]>w)
            {
                map[x][y]=w;
              
            }
        }
        scanf("%d",&count);

        for(int i=1;i<=count;i++)
        {
            scanf("%d",&a[i]);
            map[0][a[i]]=1;//我这边是将汇集到0点的边的权值设置为1,然后最后结果减去1就ok。

        }

            dijst(d,0);

        if(d[s]==wqd) printf("-1\n");
        else printf("%d\n",d[s]-1);

    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值