poj 1416 dfs

ou have just been put in charge of developing a new shredder for the Shredding Company Although a "normal" shredder would just shred sheets of paper into little pieces so that the contents would become unreadable, this new shredder needs to have the following unusual basic characteristics. 

1.The shredder takes as input a target number and a sheet of paper with a number written on it. 

2.It shreds (or cuts) the sheet into pieces each of which has one or more digits on it. 

3.The sum of the numbers written on each piece is the closest possible number to the target number, without going over it. 

For example, suppose that the target number is 50, and the sheet of paper has the number 12346. The shredder would cut the sheet into four pieces, where one piece has 1, another has 2, the third has 34, and the fourth has 6. This is because their sum 43 (= 1 + 2 + 34 + 6) is closest to the target number 50 of all possible combinations without going over 50. For example, a combination where the pieces are 1, 23, 4, and 6 is not valid, because the sum of this combination 34 (= 1 + 23 + 4 + 6) is less than the above combination's 43. The combination of 12, 34, and 6 is not valid either, because the sum 52 (= 12 + 34 + 6) is greater than the target number of 50. 
 
Figure 1. Shredding a sheet of paper having the number 12346 when the target number is 50


There are also three special rules : 

1.If the target number is the same as the number on the sheet of paper, then the paper is not cut. 

For example, if the target number is 100 and the number on the sheet of paper is also 100, then 

the paper is not cut. 

2.If it is not possible to make any combination whose sum is less than or equal to the target number, then error is printed on a display. For example, if the target number is 1 and the number on the sheet of paper is 123, it is not possible to make any valid combination, as the combination with the smallest possible sum is 1, 2, 3. The sum for this combination is 6, which is greater than the target number, and thus error is printed. 

3.If there is more than one possible combination where the sum is closest to the target number without going over it, then rejected is printed on a display. For example, if the target number is 15, and the number on the sheet of paper is 111, then there are two possible combinations with the highest possible sum of 12: (a) 1 and 11 and (b) 11 and 1; thus rejected is printed. In order to develop such a shredder, you have decided to first make a simple program that would simulate the above characteristics and rules. Given two numbers, where the first is the target number and the second is the number on the sheet of paper to be shredded, you need to figure out how the shredder should "cut up" the second number. 

Input

The input consists of several test cases, each on one line, as follows : 

tl num1 
t2 num2 
... 
tn numn 
0 0 

Each test case consists of the following two positive integers, which are separated by one space : (1) the first integer (ti above) is the target number, (2) the second integer (numi above) is the number that is on the paper to be shredded. 

Neither integers may have a 0 as the first digit, e.g., 123 is allowed but 0123 is not. You may assume that both integers are at most 6 digits in length. A line consisting of two zeros signals the end of the input. 

Output

For each test case in the input, the corresponding output takes one of the following three types : 

sum part1 part2 ... 
rejected 
error 

In the first type, partj and sum have the following meaning : 

1.Each partj is a number on one piece of shredded paper. The order of partj corresponds to the order of the original digits on the sheet of paper. 

2.sum is the sum of the numbers after being shredded, i.e., sum = part1 + part2 +... 

Each number should be separated by one space. 
The message error is printed if it is not possible to make any combination, and rejected if there is 
more than one possible combination. 
No extra characters including spaces are allowed at the beginning of each line, nor at the end of each line. 

Sample Input

50 12346
376 144139
927438 927438
18 3312
9 3142
25 1299
111 33333
103 862150
6 1104
0 0

Sample Output

43 1 2 34 6
283 144 139
927438 927438
18 3 3 12
error
21 1 2 9 9
rejected
103 86 2 15 0
rejected

Source

Japan 2002 Kanazawa

题意;就是给你两个数,将后面那个数分割 砍断,把他们的和加起来要小于前面那个数;但是又得是最大。例如第一组

输入50 12346;43就是最大的 等于1+2+34+6

思路写在注释上了

//思路:这个题目有点01背包的思想,就是砍或不砍,因为数据比较小才6位,就直接遍历整颗搜索树就好,然后判断大小,一开始可以判断这个数最小时他们各位数字之和
//如果最小的都比前面那个数大 就输出error,有相同的则判断 sum(每次的结果),ans(已经保存了的最小值)判断他们相不相等,具体的写在下面的注释上;
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int n, x,sum,ans,flag;
int count;
int b[1200];
char a[20];
void dfs(int sum,int start,int end,int count1,int &fflag)//sum表示已经分配好了的和,start表示end、表示从第几个数字到第几个数字;,fflag是个标志,提示上层要不要存取数到数组里。
{  // printf("sum=%d,start=%d,end=%d\n",sum,start,end);
    if(sum>n) return ;
    if(end==count)
    {   //printf("%d\n",sum);
        if(sum==ans) {flag=1;fflag=1;}//当他们想等,就flag=1,并且返回上层fflag保存值。
        if(ans<sum) {
                    ans=sum,fflag=1,flag=0;//小于,就返回上层的fflag。要把上层的ss到数组;

                    }
                    return ;

    }
    int ss=0;
    for(int i=start;i<=end;i++)
    {
        ss=ss*10;
        ss=ss+a[i]-'0';
    }
    int ffflag=0;
    dfs(sum+ss,end+1,end+1,count1+1,ffflag);//表示start位到end位数字把他们求和,分割出来;
    if(ffflag) {b[count1]=ss;fflag=1;}//假如ffflag为真就表示后面得到的结果比之前的ans大,就保存ss到数组,并且返回提醒上层的标志,让他们保存ss;

    int fffflag=0;
   if(end+1!=count) dfs(sum,start,end+1,count1+1,fffflag);//不分割
    if(fffflag) {b[count1]=-1;fflag=1;}//当不分割的为真,那么之前分割了就为假,所以要去掉之前分割的 将他置为-1,并且它的下层函数提示他这次的sum比之前的ans大所以他要提示上层保存ss将fflag置1;
    return ;
}
int main()
{
    while(scanf("%d%d",&n,&x)&&n&&x)
    {
        int x1=x;
           sum=0;
         count=0;
        while(x1)
        {
            sum+=x1%10;
            a[count++]=x1%10+'0';
            x1/=10;
        }
        ///printf("%d\n",sum);
        if(n>=x)  {printf("%d %d\n",x,x); continue;}
        if(sum>n) {printf("error\n"); continue;}
        int i=0;
        int j=count-1;
          /*for(int i=0;i<count;i++)
        {
            printf("%c ",a[i]);
        }*/
        while(i<j)
        {
            char t;
            t=a[i];
            a[i]=a[j];
            a[j]=t;
            i++,j--;

        }
        ans=-1;
        flag=0;
        memset(b,-1,sizeof(b));
        int fflag=0;
        dfs(0,0,0,0,fflag);
        if(flag) {printf("rejected\n"); continue;}
        printf("%d ",ans);
        int nn=0;
         for(int i=0;i<20;i++)
        {
            if(b[i]!=-1) nn++;
        }
        int mm=0;
        for(int i=0;i<20;i++)
        {
            if(b[i]!=-1)  {if(nn!=mm) printf("%d ",b[i]);
                         else  printf("%d\n",b[i]);}

        }
        printf("\n");
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值