Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
又是一道深搜的题目,这道题需要注意的地方就是,首先,把这个范围内的素数打一个表,二,注意格式,Presentation Error,在这个题上,我就因为输出格式不符被wa了好几次,无非就是中文空格,英文空格。行尾空格不能有,最后一行之后就不能再空行等等。。。
代码如下:
#include<iostream>
using namespace std;
int num;
int mark[21] = { 0,1 };
int de[20] = { 1 };
int isPerim[41] = { 0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,0,0 };
void play(int k) {
if (k >= num) {
if (isPerim[de[num - 1] + 1])
{
for (int i = 0; i < num; ++i)
{
cout << de[i];
if (i != num - 1)cout << " ";
}
cout << endl;
}
}
else {
for (int i = 1; i <=num; ++i)
{
if (!mark[i] && isPerim[de[k - 1] + i]) {
de[k] = i;
mark[i] = 1;
play(k+1);
de[k] = 0;
mark[i] = 0;
}
}
}
}
int d = 1;
int main() {
while (cin >> num)
{
cout << "Case " << d <<":"<< endl;
d++;
play(1);
memset(de, 0, sizeof(de));
memset(mark,0,sizeof(mark));
de[0] = 1;
mark[1] = 1;
cout << endl;
}
return 0;
}
using namespace std;
int num;
int mark[21] = { 0,1 };
int de[20] = { 1 };
int isPerim[41] = { 0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,0,0 };
void play(int k) {
if (k >= num) {
if (isPerim[de[num - 1] + 1])
{
for (int i = 0; i < num; ++i)
{
cout << de[i];
if (i != num - 1)cout << " ";
}
cout << endl;
}
}
else {
for (int i = 1; i <=num; ++i)
{
if (!mark[i] && isPerim[de[k - 1] + i]) {
de[k] = i;
mark[i] = 1;
play(k+1);
de[k] = 0;
mark[i] = 0;
}
}
}
}
int d = 1;
int main() {
while (cin >> num)
{
cout << "Case " << d <<":"<< endl;
d++;
play(1);
memset(de, 0, sizeof(de));
memset(mark,0,sizeof(mark));
de[0] = 1;
mark[1] = 1;
cout << endl;
}
return 0;
}