HDU 1057 What Are You Talking About(字典树)

Time Limit: 5000MS Memory Limit: 204800KB 64bit IO Format: %I64d & %I64u

 Status

Description

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him? 

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters. 

Output

In this problem, you have to output the translation of the history book. 

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END

Sample Output

hello, i'm from mars.
i like earth!


思路其实很简单,就是把火星文加到字典树里面,在尾字符加入对应的翻译。就是文章的处理不好弄。还是没能把getline完全弄明白。只知道他输入一行然后赋值给string变量,然后在这个字符串里面遍历,如果是小写字母就加到初始化为空的字符串ss中,知道不是小写字母,然后把ss到树上查一遍,有对应的就输出对应的值,没有就输出本来的。然后依次输出字符和空格即可。。。。还是wa了好几次,因为getline的原因,因为cin输入字符串的时候没有把结束符也输入进去,然后在cin>>ss,的后面第一句etline(cin,str),这个str会存储上一行残留的结束符,从而str为空。。。从而我莫名其妙的wa了好几次

代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxx=1000000;
int ch[maxx][26];
string value[maxx];
int sz=0;
void init()
{
    sz=1;
    memset(ch[0],0,sizeof(ch[0]));
}

void insertstr(string str,string str2)
{
    int u=0,n=str.length();
    for(int i=0; i<n; i++)
    {
        int d=str[i]-'a';
        if(!ch[u][d])
        {
            memset(ch[sz],0,sizeof(ch[sz]));
            value[sz]="";
            ch[u][d]=sz++;
        }
        u=ch[u][d];
    }
    value[u]=str2;
}

string findstr(string str)
{
    int u=0,n=str.length();
    for(int i=0; i<n; i++)
    {
        int d=str[i]-'a';
        if(ch[u][d])u=ch[u][d];
        else return str;
    }
    if(value[u]!="")
        return value[u];
    else return str;
}

int main()
{
    ios_base::sync_with_stdio(false);
    string str;
    string str1;
    cin>>str;init();
    while(cin>>str&&str!="END")
    {
        cin>>str1;
        insertstr(str1,str);
    }
  getline(cin,str1);
    while(true)
    {
        getline(cin,str1);
        if(str1=="START")continue;
        if(str1=="END")break;
        str="";
        int n=str1.length();
        for(int i=0; i<n; i++)
        {
            if(str1[i]>='a'&&str1[i]<='z')str=str+str1[i];
            else
            {
                if(str!="")cout<<findstr(str);
                cout<<str1[i];
                str="";
            }
        }
        cout<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值