Permutation Descent Counts CSU 1968 (动态规划)

Description

Given a positive integer, N, a permutation of order N is a one-to-one (and thus onto) function from the set of integers from 1 to N to itself. If p is such a function, we represent the function by a list of its values: [ p(1) p(2) … p(N) ]

For example,
[5 6 2 4 7 1 3] represents the function from { 1 … 7 } to itself which takes 1 to 5, 2 to 6, … , 7 to 3.
For any permutation p, a descent of p is an integer k for which p(k) > p(k+1). For example, the permutation [5 6 2 4 7 1 3] has a descent at 2 (6 > 2) and 5 (7 > 1).
For permutation p, des(p) is the number of descents in p. For example, des([5 6 2 4 7 1 3]) = 2. The identity permutation is the only permutation with des(p) = 0. The reversing permutation with p(k) = N+1-k is the only permutation with des(p) = N-1 .

The permutation descent count (PDC) for given order N and value v is the number of permutations p of order N with des(p) = v. For example:

PDC(3, 0) = 1 { [ 1 2 3 ] }
PDC(3, 1) = 4 { [ 1 3 2 ], [ 2 1 3 ], [ 2 3 1 ], 3 1 2 ] }
PDC(3, 2) = 1 { [ 3 2 1 ] }`

Write a program to compute the PDC for inputs N and v. To avoid having to deal with very large numbers, your answer (and your intermediate calculations) will be computed modulo 1001113.

Input

The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. Each data set should be processed identically and independently.

Each data set consists of a single line of input. It contains the data set number, K, followed by the integer order, N (2 ≤ N ≤ 100), followed by an integer value, v (0 ≤ v ≤ N-1).

Output

For each data set there is a single line of output. The single output line consists of the data set number, K, followed by a single space followed by the PDC of N and v modulo 1001113 as a decimal integer.

Sample Input

4
1 3 1
2 5 2
3 8 3
4 99 50

Sample Output

1 4
2 66
3 15619
4 325091

Hint

Source

2017湖南多校第十三场

题目分析:其实题目意思很明确的,状态都已经给出。dp[i][j]表示第i个数的排列是逆序数对的个数为j个。然后找出状态转移方程。

dp[i][j] = (dp[i-1][j]*(j+1)+dp[i-1][j-1]*(i-j));

因为1,3,2中此时逆序数对的间隔为4个,其中,你在插入一个数字4,会发现插入到当前的逆序数对中和末尾不会改变逆序数对个数。而插入到其他的位置会使得逆序数对数加一。

代码入下:

/* Author:kzl */
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>

using namespace std;
const int mod = 1001113;
const int maxx = 105;
int p,k,n,v;
int dp[maxx][maxx];

void calc(){
memset(dp,0,sizeof(dp));
dp[2][0] = 1;
dp[2][1] = 1;
for(int i=3;i<=100;i++)
{
    dp[i][0] = 1;
    for(int j=1;j<i-1;j++)
    {
    dp[i][j] = (dp[i-1][j]*(j+1)+dp[i-1][j-1]*(i-j));
     dp[i][j]%=mod;
    }
    dp[i][i-1] = 1;
}
}

int main(){
    calc();
scanf("%d",&p);
while(p--)
{
    scanf("%d%d%d",&k,&n,&v);
    printf("%d %d\n",k,dp[n][v]);
}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值