POJ 1328 Radar Installation (贪心)

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 56811 Accepted: 12809

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

= = 虽然这道题有1W+人过了 一开始想偏总是觉得可以固定下每个雷达的点

事实上 贪心的思路是 先预处理每个岛的放置雷达的点区间 且按照起始点区间排序

如果雷达放置区间被当前区间包含 那么此时要更新雷达放置区间为当前区间  两区间相交不做处理

如果 两区间不相交 那么就要再建设一个雷达 并更新雷达的所处区间

AC代码如下:

//
//  POJ 1328 Radar Installation
//
//  Created by TaoSama on 2015-02-22
//  Copyright (c) 2015 TaoSama. All rights reserved.
//
#include <algorithm>
#include <cctype>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <map>
#include <queue>
#include <string>
#include <set>
#include <vector>
#define CLR(x,y) memset(x, y, sizeof(x))

using namespace std;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 1e5 + 10;

struct Seg {
	double l, r;
	bool operator<(const Seg& s) const {
		return l < s.l;
	}
} a[1005];
int n, kase, d;

int main() {
#ifdef LOCAL
	freopen("in.txt", "r", stdin);
//	freopen("out.txt","w",stdout);
#endif
	ios_base::sync_with_stdio(0);

	while(cin >> n >> d && n && d) {
		bool ok = true;
		for(int i = 1; i <= n; ++i) {
			int x, y; cin >> x >> y;
			double t = sqrt(d * d - y * y);
			a[i].l = x - t; a[i].r = x + t;
			if(y > d) ok = false;
		}
		int ans = -1;
		if(ok) {
			sort(a + 1, a + 1 + n);
			ans = 1;
			Seg t = a[1];
			for(int i = 2; i <= n; ++i) {
				if(t.r > a[i].r)
					t = a[i];
				else if(t.r < a[i].l) {
					++ ans;
					t = a[i];
				}
			}
		}
		cout << "Case " << ++kase << ": " << ans << endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值