POJ 3181 Dollar Dayz (dp)

Dollar Dayz
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4442 Accepted: 1716

Description

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 

        1 @ US$3 + 1 @ US$2

        1 @ US$3 + 2 @ US$1

        1 @ US$2 + 3 @ US$1

        2 @ US$2 + 1 @ US$1

        5 @ US$1
Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5

划分数 dp[i][j] = dp[i-1][j] + dp[i][j-i];

- - 要高精 然后dph高位 dpl低位 滚动数组优化

AC代码如下:

//
//  POJ 3181 Dollar Dayz
//
//  Created by TaoSama on 2015-03-05
//  Copyright (c) 2015 TaoSama. All rights reserved.
//
#include <algorithm>
#include <cctype>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <map>
#include <queue>
#include <string>
#include <set>
#include <vector>
#define CLR(x,y) memset(x, y, sizeof(x))

using namespace std;
const int INF = 0x3f3f3f3f;
const long long MOD = 1e18;
const int N = 1e5 + 10;

int n, k;
long long dph[N], dpl[N]; //¸ßλµÍλ
int main() {
#ifdef LOCAL
	freopen("in.txt", "r", stdin);
//	freopen("out.txt","w",stdout);
#endif
	ios_base::sync_with_stdio(0);

	while(cin >> n >> k) {
		memset(dph, 0, sizeof dph);
		memset(dpl, 0, sizeof dpl);
		dpl[0] = 1;
		for(int i = 1; i <= k; ++i) {
			for(int j = i; j <= n; ++j) {
				dph[j] = dph[j] + dph[j - i] + (dpl[j] + dpl[j - i]) / MOD;
				dpl[j] = (dpl[j] + dpl[j - i]) % MOD;
			}
		}
		if(!dph[n]) cout<<dpl[n]<<endl;
		else	cout<<dph[n]<<setw(18)<<setfill('0')<<dpl[n]<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值