POJ 2184 Cow Exhibition (dp)

Cow Exhibition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9687 Accepted: 3747

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

非常经典的一道题 - - 由于每个存在装和不装的情况 所以是01背包变种

s作为容量 f作为背包 由于存在负数下标 1e5作为偏移量

负数的情况要将01背包j循环正序 具体看一下转移方程就明白了 因为01是选一次

AC代码如下:

//
//  POJ 2184 Cow Exhibition
//
//  Created by TaoSama on 2015-03-06
//  Copyright (c) 2015 TaoSama. All rights reserved.
//
#include <algorithm>
#include <cctype>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <map>
#include <queue>
#include <string>
#include <set>
#include <vector>
#define CLR(x,y) memset(x, y, sizeof(x))

using namespace std;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 2e5 + 10;

int n, s[105], f[105], dp[N];

int main() {
#ifdef LOCAL
	freopen("in.txt", "r", stdin);
//	freopen("out.txt","w",stdout);
#endif
	ios_base::sync_with_stdio(0);

	while(cin >> n) {
		for(int i = 1; i <= n; ++i)
			cin >> s[i] >> f[i];

		memset(dp, 0xc0, sizeof dp);
		int center = 1e5, range = 2e5;
		dp[center] = 0;
		for(int i = 1; i <= n; ++i) {
			if(s[i] < 0 && f[i] < 0) continue;
			else if(s[i] > 0) {
				for(int j = range; j >= s[i]; --j)
					dp[j] = max(dp[j], dp[j - s[i]] + f[i]);
			} else {
				for(int j = 0; j <= range + s[i]; ++j)
					dp[j] = max(dp[j], dp[j - s[i]] + f[i]);
			}
		}
		int ans = -INF;
		for(int i = center; i <= range; ++i)
			if(dp[i] >= 0) ans = max(ans, dp[i] + i - center);
		cout << ans << endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值