poj2479 Maximum sum

Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 37096 Accepted: 11570
Description

Given a set of n integers: A={a1, a2,…, an}, we define a function d(A) as below:

Your task is to calculate d(A).
Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, …, an. (|ai| <= 10000).There is an empty line after each case.
Output

Print exactly one line for each test case. The line should contain the integer d(A).
Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5
Sample Output

13
Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.

Huge input,scanf is recommended.

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
/*代码一:TLE 
int main()
{
    int a[50001];
    int left[50001];
    int right[50001];
    int T; 
    int n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        //left[i]表示i(包括i)左边最大字段和 
         left[0]=a[0];
         for(int i=1;i<n;i++)
         {
            if(left[i-1]<0)
                left[i]=a[i];
            else
                left[i]=left[i-1]+a[i];
         }
         //right[i]表示i(包括i)右边最大字段和 
         right[n-1]=a[n-1]; 
         for(int i=n-2;i>=0;i--)
         {
            if(right[i+1]<0)
                right[i]=a[i];
            else
                right[i]=right[i+1]+a[i];
         }

         int temp=-10000;
         for(int i=0;i<n;i++)
         {
         for(int j=i+1;j<n;j++)
            if(temp<(left[i]+right[j]))
                temp=left[i]+right[j];
         }
         for(int i=0;i<n;i++)
         if(temp<(left[i]+right[i+1])) 
            temp=left[i]+right[i+1];
        printf("%d",temp);
    }
    return 0;
}
*/ 

//只接受O(N)的算法 


int main()
{
    int a[50001];
    int left[50001];
    int right[50001];
    int T; 
    int n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        //left[i]表示i(包括i)左边最大字段和 
         left[0]=a[0];
         for(int i=1;i<n;i++)
         {
            if(left[i-1]<0)
                left[i]=a[i];
            else
                left[i]=left[i-1]+a[i];
         }
         //left[i]表示i左边的最大字段和
         for(int i=1;i<n;i++)
         {
            left[i]=max(left[i],left[i-1]);
         } 
         //right[i]表示i(包括i)左边最大字段和 
         right[n-1]=a[n-1]; 
         for(int i=n-2;i>=0;i--)
         {
            if(right[i+1]<0)
                right[i]=a[i];
            else
                right[i]=right[i+1]+a[i];
         }
         //right[i]表示i 右边最大字段和
         for(int i=n-2;i>=0;i--)
            right[i]=max(right[i],right[i+1]) ;
         int temp=-10000;
        for(int i=0;i<n-1;i++)
            if(temp<(left[i]+right[i+1]))
                temp=left[i]+right[i+1];
        printf("%d\n",temp);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值