POJ1222 EXTENDED LIGHTS OUT

EXTENDED LIGHTS OUT

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8006 Accepted: 5207
Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.

Note:
1. It does not matter what order the buttons are pressed.
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.
Write a program to solve the puzzle.
Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.
Output

For each puzzle, the output consists of a line with the string: “PUZZLE #m”, where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1’s indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.
Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0
Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

枚举要点:
1.给出解空间, 建立简洁的数学模型(枚举什么?)
2.减少搜索的空间(尽快排除错误答案)
3.采用合适的搜索顺序
下面代码是我学习了Coursera上的《算法基础》后自己写的代码

#include<iostream>
//#include<cstdlib>
#include<cstring>
using namespace std;
//防止分类讨论给5行6列的区域加一边框
int state[6][8];
int press[6][8];

int main()
{
    int n;
    int t=1;
    int count;
    cin>>n;
    memset(press,0,sizeof(press));
    memset(state,0,sizeof(state));
    //读入数据
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=5;i++)
        {
            for(int j=1;j<=6;j++)
            {
                cin>>state[i][j];
            }
        }
        //枚举(只对第一行的press状态进行枚举)
        for(int a=0;a<2;a++)
        for(int b=0;b<2;b++)
        for(int c=0;c<2;c++)
        for(int d=0;d<2;d++)
        for(int e=0;e<2;e++)
        for(int f=0;f<2;f++)
        {
            count=0;//注意 
            press[1][1]=a;
            press[1][2]=b;
            press[1][3]=c;
            press[1][4]=d;
            press[1][5]=e;
            press[1][6]=f;
            //关掉第一行灯只需要操作第二行的press
            //关掉第二行灯需要操作第三行的press
            //以此类推
            //确定2到5行的press转态
            for(int i=2;i<=5;i++)
            {
                for(int j=1;j<=6;j++)
                {
                    press[i][j]=(state[i-1][j]+press[i-1][j-1]+press[i-1][j]+press[i-1][j+1]+press[i-2][j])%2;
                }
            }
            //判断第五行的灯是否全灭,用count技术灭了的灯数
            for(int i=1;i<=6;i++)
            {
                if((press[5][i]+press[5][i-1]+press[5][i+1]+press[4][i])%2==state[5][i])
                    count++;
            }
            if(count==6)
            {
                cout<<"PUZZLE #"<<k<<endl;
                for(int i=1;i<=5;i++)
                {
                    for(int j=1;j<=6;j++)
                    {
                        cout<<press[i][j]<<" ";
                    }
                    cout<<endl;
                }
            }
        }
    }
    return 0;
}

对上述代码进行优化
优化内容:
1.将枚举方式和找press解法分别作为一个函数,增强代码可读性
2.优化枚举方式,将六重循环改为通过++操作二进制数来枚举

#include<iostream>
#include<cstring>
using namespace std;
int state[6][8];
int press[6][8];
bool solution()
{
    // 根据press第一行和state数组计算press其它行的值 
    for(int i=2;i<=5;i++) 
    for(int j=1;j<=6;j++)
    {
        press[i][j]=(state[i-1][j]+press[i-1][j-1]+press[i-1][j]+press[i-1][j+1]+press[i-2][j])%2;
    }
    // 判断计算所得的press数组是否能熄灭第五行灯 
    for(int i=1;i<=6;i++)
        if((press[5][i]+press[5][i-1]+press[5][i+1]+press[4][i])%2!=state[5][i])
            return false;
    return true;        
}
void enumerate()
{
    for(int i=1;i<=6;i++)
        press[1][i]=0;
    while(solution()==false)
    {
        press[1][1]++;
        int c=1;
        //模拟二进制数加法 
        while(press[1][c]>1)
        {
            press[1][c]=0;
            c++;
            press[1][c]++;
        }

    }
}
int main()
{
    int n;
    cin>>n;
    //初始化 
    memset(press,0,sizeof(press));
    memset(state,0,sizeof(state));
    for(int k=1;k<=n;k++)
    {
        //数据输入 
        for(int i=1;i<=5;i++)
            for(int j=1;j<=6;j++)
                cin>>state[i][j];
        enumerate();
        //数据输出 
        cout<<"PUZZLE #"<<k<<endl;
        for(int i=1;i<=5;i++)
        {
            for(int j=1;j<=6;j++)
                cout<<press[i][j]<<" ";
            cout<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值