HDU1028

HDU1028
Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21783 Accepted Submission(s): 15208

Problem Description
“Well, it seems the first problem is too easy. I will let you know how foolish you are later.” feng5166 says.

“The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+…+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3” is the same in this problem. Now, you do it!”

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input
4
10
20

Sample Output
5
42
627

Author
Ignatius.L

Recommend
We have carefully selected several similar problems for you: 1171 1085 1398 2152 1709


**题目分析:
拆分整数,拆为为n个整数的和的方案有多少种,重复无效。一开始知道推递推式用动态规划做,后面了解到了母函数;一个求多重组合类型题的函数。
**

//母函数法
#include <iostream>
using namespace std;
const int N = 121;
int c1[N], c2[N];
int main()
{
    int n, i, j, k;
    while (cin >> n)
    {
        memset(c1, 0, sizeof(c1));
        memset(c2, 0, sizeof(c2));
        for (i = 0; i <= n; i++)//i的作用是表示所求的x^i
            c1[i] = 1;//c1[i]即x^i的系数,也是对用n=i的输出结果,这里求出了当i=1的值
        for (i = 2; i <= n; i++)
        {
            for (j = 0; j <= n; j++)//j的作用是当前括号里的x^j
                for (k = 0; k + j <= n; k += i)//k的作用是表示当前可用于计算的x^k
                                            //例如当n=4,i=3时4=3+1
                                            //k+j>n求出无意义,所以限制
                {
                    c2[j + k] += c1[j];//只有j有系数c1[j]
                }
            for (j = 0; j <= n; j++)
            {
                c1[j] = c2[j];
                c2[j] = 0;
            }
        }
        cout << c1[n] << endl;
    }
    return 0;
}

拆分整数就是把整数n拆分成不大于m的数之和即cf[n][m]
由题目举例:
当n=3,m=1时,只有1种:{1,1,1};cf[3][1]=1;
当n=3,m=2时,只有2种{1,1,1},{2,1};cf[3][2]=2;
当n=3,m=3时,只有3种{1,1,1},{2,1},{3};cf[3][3]=3;
当n=3,m=4时,只有3种{1,1,1},{2,1},{3};cf[3][4]=3;
当n=4,m=1时,只有1种:{1,1,1,1};cf[4][1]=1;
当n=4,m=2时,只有3种{1,1,1,1},{2,1,1},{2,2};cf[4][2]=3;
当n=4,m=3时,只有4种{1,1,1,1},{2,1,1},{2,2},{3,1};cf[4][3]=4;
当n=4,m=4时,只有5种{1,1,1,1},{2,1,1},{2,2},{3,1},{4};cf[4][4]=5
当n=4,m=5时,只有5种{1,1,1,1},{2,1,1},{2,2},{3,1},{4};cf[4][5]=5
从上面我们可以发现:
当n==1||m==1时,只有一种分法;
当n< m时,cf[n][m]=cf[n][n];
当n==m时,cf[n][n]=1+cf[n][n-1];
当n>m时,cf[n][m]=cf[n-m][m]+cf[n][m-1];

//动态规划
#include<iostream>
using namespace std;
int cf[122][122] = { 0 };
int main()
{
    int i, j;
    for (i = 1; i <= 121; i++)
        cf[1][i] = cf[i][1] = 1;
    for (i = 2; i<121; i++)
    {
        for (j = 2; j <= 121; j++)
        {
            if (i<j)
                cf[i][j] = cf[i][i];
            else if (i == j)
                cf[i][j] = 1 + cf[i][j - 1];
            else if (i>j)
                cf[i][j] = cf[i - j][j] + cf[i][j - 1];
        }
    }
    int n;
    while (cin >> n)
        cout << cf[n][n] << endl;
    return 0;
}
  • 4
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值