An easy problem
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14069 Accepted Submission(s): 3892
Problem Description
We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.
Now there is a very easy problem . I think you can AC it.
We can define sum(n) as follow:
if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i;
Is it very easy ? Please begin to program to AC it..-_-
Input
The input file contains multilple cases.
Every cases contain only ont line, every line contains a integer n (n<=100000).
when n is a negative indicate the end of file.
Output
output the result sum(n).
Sample Input
1
2
3
-1
Sample Output
1
3
30
Author
Wendell
Source
HDU 2007-11 Programming Contest_WarmUp
这道题可以简单模拟,也可数学推导公式(数学不好的噩梦)
数学分析见原文
本题对数据的格式有要求,按公式做的n必须也为长整型,模拟的就不用,模拟花的时间少,公式花的空间少
#include<cstdio>
int main()
{
long long sum, temp,n;
while (scanf("%lld",&n)&&n>=0)
{
temp = 0;
if (n % 3 == 1)
{
temp = n;
n--;
}
else if (n % 3 == 2)
{
temp = 2 * n - 1;
n -= 2;
}
sum = n / 3 * (n / 3 + 1) / 2;
sum *= sum;
sum = sum * 27 + n*(n + 1) / 2 - n*(n + 3) / 6;
printf("%I64d\n", sum + temp);
}
return 0;
}
#include<cstdio>
int main()
{
long long a[100001] = { 0,1,3 },i;
for ( i = 3; i < 100001; i++)
{
if (i % 3 == 0)
a[i] = a[i - 1] + i*i*i;
else
a[i] = a[i - 1] + i;
}
int n;
while (scanf("%d",&n)&&n>=0)
{
printf("%I64d\n", a[n]);
}
return 0;
}