问题 A: Least Common Multiple

题目描述

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

输入

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

输出

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

样例输入 Copy

2
2 3 5
3 4 6 12

样例输出 Copy

15
12

 

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string>
using namespace std;
int gcd(int a, int b){
	if(b == 0) return a;
	else return gcd(b, a % b);
}

int main(int argc, char** argv) {
	int n;
	while(cin >> n){
		for(int i = 0; i < n; i++){
			int m;
			cin >> m;
			int a[m];
			for(int j = 0; j < m; j++){
				cin >> a[j];
			}
			int r;
			for(int j = 0; j < m - 1; j++){
				a[j + 1] = a[j + 1] / gcd(a[j], a[j + 1]) * a[j];//这里先除再乘,不然会溢出
			}
			cout << a[m - 1] << endl;
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值