ACM-贪心之Fat Mouse Trade——hdu1009

FatMouse' Trade


Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

一道贪心算法的题目,题目大体内容为,有一只老鼠他有一些猫食,他想用猫食换他喜欢吃的豆子,
相应比例的猫食,可以换相应比例的豆子,例如 一个门里有 7 豆 2猫食,  老鼠用一个猫食可以换
3.5个豆子(二分之一)。求老鼠最多换多少豆子。

贪心的惯用方法,求性价比,排序,开始换,then我的程序:
//*******************************************************
//*  程 序 名:hdu_1009.cpp				*
//*														*
//*  作    者:Tree				    *
//*														*
//*  编制时间:2013年9月27日				*
//*														*
//*  主要功能:hdu 1009 FatMouse' Trade 		*
//*														*
//*******************************************************



#include <iostream>
#include <iomanip>				//要求三位小数
using namespace std;

struct room{
	double catfood;
	double javabean;
	double propor;				//存贮性价比,proportion-比重
};

int main()
{
	room rm[10001],temp;
	int m,n;
	double sum;
	int i,j;


	while(cin>>m>>n)
	{
		if(-1==m&&-1==n)
			break;

		// 存储
		for(i=0;i<n;++i)
		{
			cin>>rm[i].javabean>>rm[i].catfood;
			rm[i].propor=rm[i].javabean/rm[i].catfood;
		}
		
		// 排序  用了简单的冒泡排序(从大到小排)
		for(j=0;j<n;++j)
			for(i=0;i<n-1;++i)
			if(rm[i].propor<rm[i+1].propor)
			{
				temp=rm[i];
				rm[i]=rm[i+1];
				rm[i+1]=temp;
			}

		// 计算
		sum=0;
		
		for(i=0;i<n;++i)
		{
			if(m>=rm[i].catfood)
			{
				sum+=rm[i].javabean;
				m-=rm[i].catfood;
			}
			else
			{
				sum+=rm[i].propor*m;
				break;
			}
		}

		cout<<setiosflags(std::ios::fixed)<<setprecision(3)<<sum<<endl;

	}

	return 0;
}


 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值