ACM-水题之Digital Roots——hdu1013

好吧,这几天刷一些水题找找感觉,

发现,一段时间不练,水平下降好多啊,

做个水题都磨蹭半天了。。。。

 

Digital Roots


Problem Description

 

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 


 

Input

 

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 


 

Output

 

For each integer in the input, output its digital root on a separate line of the output.
 


 

Sample Input

 

  
  
24 39 0
 


 

Sample Output

 

  
  
6 3
 

 

 

 

够水的题吧,我原来程序是这样的:

#include <iostream>
using namespace std;
int main()
{	
	int n,j;
	while(cin>>n&&n!=0&&n>0)
	{
		
		do
		{
			j=0;
			while(n>9)
			{
				j+=n%10;
				n/=10;
			}
			j+=n;
			n=j;
		}while(n>9);
		cout<<n<<endl;
		
	}
		
	return 0;
}


怎么看,怎么没有错,就是WA,我快崩溃了>_<!

 

后来才发现没有考虑大数的问题。。。。题目中也没有说数有多大,挺坏的。。。

 

所以,改正后:

 

#include <iostream>
#include <string.h>

using namespace std;
int main()
{
	char a[10000];
	int i,j,sum;

	while(cin>>a&&a[0]!='0')
	{
		sum=0;
		for(i=0;i<strlen(a);++i)
				sum+=(a[i]-'0');
		if(sum<10)
		{
			cout<<sum<<endl;
			continue;
		}
		
		do
		{
			j=0;
			while(sum>9)
			{
				j+=sum%10;
				sum/=10;
			}
			j+=sum;
			sum=j;
		}while(sum>9);
		cout<<sum<<endl;
		
		
		

	}


	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值