1.将拨号失败的名字修改到pppoe-out100以后
:gl lt 100
/interface pppoe-cl
:foreach i in [find name~"pppoe-out"] do={:if [get $i running ] do={} else={
set $i name=("pppoe-out".$lt)
:set $lt ($lt+1)
}}
/
2.调整拨号顺序后修正所有拨号的路由和profile
:gl array {192.168.10.1;192.168.10.2;192.168.10.3;192.168.10.4;192.168.10.5;192.168.10.6;192.168.10.7;192.168.10.8;192.168.10.9;192.168.10.10;192.168.10.11;192.168.10.12;192.168.10.13;192.168.10.14;192.168.10.15;192.168.10.16;192.168.10.17;192.168.10.18;192.168.10.19;192.168.10.20;192.168.10.21;192.168.10.22;192.168.10.23;192.168.10.24;192.168.10.25;192.168.10.26;192.168.10.27;192.168.10.28;192.168.10.29;192.168.10.30;192.168.10.31;192.168.10.32}
:gl ip
:gl k
:gl j
:set k 1
:set j 32
:for i from=$k to=$j do={
:set ip [:pick $array ($i-1)]
:put $ip
/ip route set [find dst-address=($ip."/32")] gateway=("pppoe-out".$i)
/ip route set [find routing-mark=("r" .$i)] gateway=("pppoe-out".$i)
}
/interface pppoe-client
:for i from=$k to=$j do={ set [find name=("pppoe-out".$i)] profile=("profile".$i)}
/
3.快速将不连续的IP加入到地址池中
######添加地址池
:gl a ""
:gl server 22
:gl m 24
:gl n 48
/ip pool
:for i from=$m to=$n do={
:set a ($a."10.4.".$i.".$server,")
}
add name=gx101 range=$a
/