算法分析与复杂性理论 第三题 Til the Cows Come Home

总时间限制: 
1000ms 
内存限制: 
65536kB
描述
Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
输入
* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
输出
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
样例输入
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
样例输出
90
提示
INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.
来源
USACO 2004 November

注意可能出现重边。

邻接矩阵:

#include <iostream>
#include <cstdio>
#include <limits.h>

using namespace std;

int n, t;
int trail[1010][1010];
int minDistance[1010];
bool isVisited[1010];

void dijstra(int root)
{
    isVisited[root] = true;
    int visitedNum = 1;
    int nowVisited = root;
    minDistance[root] = 0;
    while(visitedNum <= n)
    {
        int minDis = INT_MAX;
        int nextVisited = -1;
        for(int i = 1; i <= n; i++)
        {
            if(i == nowVisited || i == root)
                continue;
            if(!isVisited[i] && trail[nowVisited][i] != INT_MAX && minDistance[i] > minDistance[nowVisited] + trail[nowVisited][i])
            {
                minDistance[i] = minDistance[nowVisited] + trail[nowVisited][i];
            }
            if(!isVisited[i] && minDistance[i] < minDis)
            {
                minDis = minDistance[i];
                nextVisited = i;
            }
        }
        isVisited[nextVisited] = true;
        visitedNum ++;
        nowVisited = nextVisited;
    }
}

int main()
{
    for(int i = 0; i < 1010; i++)
    {
        for(int j = 0; j < i; j++)
            trail[i][j] = trail[j][i] = INT_MAX;
        trail[i][i] = 0;
        minDistance[i] = INT_MAX;
        isVisited[i] = false;
    }
    cin >> t >> n;
    for(int i = 0; i < t; i++)
    {
        int x, y, d;
        cin >> x >> y >> d;
        if(trail[x][y] > d)
            trail[x][y] = trail[y][x] = d;
    }
    dijstra(1);
    cout << minDistance[n] << endl;
    return 0;
}

领接表:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <string.h>
#include <algorithm>
#include <vector>

using namespace std;

const int INF = 0x3f3f3f3f;
typedef struct trail
{
    int v;
    int l;
}tra;

int t, n;
vector< vector<tra> > way(1005);
bool visited[1005];
int cost[1005];

void dij()
{
    memset(visited, 0, sizeof(visited));
    memset(cost, INF, sizeof(cost));
    int next = 0;
    for(int i = 0; i < way[1].size(); i++)
    {
        if(cost[way[1][i].v] > way[1][i].l)
            cost[way[1][i].v] = way[1][i].l;
        if(cost[way[1][i].v] < cost[next])
            next = way[1][i].v;
    }

    while(next)
    {
        int now = next;
        next = 0;
        visited[now] = true;
        for(int i = 0; i < way[now].size(); i++)
        {
            int j = way[now][i].v;
            if(!visited[j] && cost[j] > cost[now] + way[now][i].l)
            {
                cost[j] = cost[now] + way[now][i].l;
            }
        }
        for(int i = 1; i <= n; i++)
            if(!visited[i] && cost[i] < cost[next])
                next = i;
    }
}

int main()
{
    scanf("%d%d", &t, &n);
    while(t--)
    {
        int i, j, c;
        scanf("%d%d%d", &i, &j, &c);
        tra a;
        a.v = j;
        a.l = c;
        way[i].push_back(a);
        a.v = i;
        way[j].push_back(a);
    }
    dij();
    printf("%d\n", cost[n]);
    return 0;
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值