算法设计 第二次上机 Subway

总时间限制: 
1000ms 
内存限制: 
65536kB
描述
You have just moved from a quiet Waterloo neighbourhood to a big, noisy city. Instead of getting to ride your bike to school every day, you now get to walk and take the subway. Because you don't want to be late for class, you want to know how long it will take you to get to school. 
You walk at a speed of 10 km/h. The subway travels at 40 km/h. Assume that you are lucky, and whenever you arrive at a subway station, a train is there that you can board immediately. You may get on and off the subway any number of times, and you may switch between different subway lines if you wish. All subway lines go in both directions.
输入
Input consists of the x,y coordinates of your home and your school, followed by specifications of several subway lines. Each subway line consists of the non-negative integer x,y coordinates of each stop on the line, in order. You may assume the subway runs in a straight line between adjacent stops, and the coordinates represent an integral number of metres. Each line has at least two stops. The end of each subway line is followed by the dummy coordinate pair -1,-1. In total there are at most 200 subway stops in the city.
输出
Output is the number of minutes it will take you to get to school, rounded to the nearest minute, taking the fastest route.
样例输入
0 0 10000 1000
0 200 5000 200 7000 200 -1 -1 
2000 600 5000 600 10000 600 -1 -1
样例输出
21
来源
Waterloo local 2001.09.22

注意,memset不能用于float数组的赋值!!!!!!!!

将每个地铁站以及家、学校的位置作为一个点,计算各点之间的距离。


#include <iostream>
#include <stdio.h>
#include <math.h>
#include <climits>
#include <float.h>
#include <string.h>
#include <stdlib.h>

using namespace std;

float graph[205][205];
int cor[205][2];
int station;
bool isvisit[205];
float dis[205];

float getdis(int x1, int y1, int x2, int y2)
{
    return sqrt((x1 - x2) * (x1 - x2) + (y1 - y2) * (y1 - y2));
}

void dijkstra()
{
    for(int i = 0; i < station; i++)
        dis[i] = -1.0;
    memset(isvisit, false, sizeof(isvisit));
    int now = 0;
    isvisit[0] = true;
    dis[0] = 0;
    for(int i = 1; i < station; i++)
    {
        float mindis = -1.0;
        int next = -1;
        for(int j = 1; j < station; j++)
        {
            if(j == now)
                continue;
            if(!isvisit[j])
            {
                if( dis[j] == -1.0 || dis[j] > dis[now] + graph[now][j])
                {
                    dis[j] = dis[now] + graph[now][j];
                }
                if(mindis == -1.0 || dis[j] < mindis)
                {
                    mindis = dis[j];
                    next = j;
                }
            }
        }
        now = next;
        isvisit[now] = true;
    }
}

int main()
{
    //freopen("test.txt", "r", stdin);
    int x0, y0, x1, y1;
    station = 2;

    cin >> x0 >> y0 >> x1 >> y1;
    //cout << x0 << "\t" << y0 << "\t" << x1 << "\t" << y1 << endl;

    cor[0][0] = x0;
    cor[0][1] = y0;
    cor[1][0] = x1;
    cor[1][1] = y1;

    graph[0][1] = graph[1][0] = getdis(x0, y0, x1, y1) / 10000 * 60;

    while(cin >> x0 >> y0)
    {
        //cout << x0 << "\t" << y0 << "\t";
        cor[station][0] = x0;
        cor[station][1] = y0;
        station ++;
        for(int i = 0; i < station -1; i ++)
        {
            graph[i][station - 1] = graph[station - 1][i] = getdis(x0, y0, cor[i][0], cor[i][1]) / 10000 * 60;
            //cout << "graph[" << i << "][" << station - 1 << "]:" << graph[i][station - 1] << endl;
        }
        cin >> x1 >> y1;
        //cout << x1 << "\t" << y1 << "\t" << endl;
        while(x1 != -1 && y1 != -1)
        {
            cor[station][0] = x1;
            cor[station][1] = y1;
            station ++;
            //cout << station << endl;
            for(int i = 0; i < station -2; i ++)
            {
                graph[i][station - 1] = graph[station - 1][i] = getdis(x1, y1, cor[i][0], cor[i][1]) / 10000 * 60;
                //cout << "graph[" << i << "][" << station - 1 << "]:" << graph[i][station - 1] << endl;
            }
            graph[station - 2][station - 1] = graph[station - 1][station - 2] = getdis(x1, y1, cor[station - 2][0], cor[station - 2][1]) / 40000 * 60;
            //cout << "graph[" << station - 2 << "][" << station - 1 << "]:" << graph[station - 2][station - 1] << endl;
            cin >> x1 >> y1;
            //cout << x1 << "\t" << y1 << "\t" << endl;
        }
    }
    dijkstra();
    cout << int(dis[1] + 0.5) << endl;
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值