算法设计 第二次上机 Subway

总时间限制: 
1000ms 
内存限制: 
65536kB
描述
You have just moved from a quiet Waterloo neighbourhood to a big, noisy city. Instead of getting to ride your bike to school every day, you now get to walk and take the subway. Because you don't want to be late for class, you want to know how long it will take you to get to school. 
You walk at a speed of 10 km/h. The subway travels at 40 km/h. Assume that you are lucky, and whenever you arrive at a subway station, a train is there that you can board immediately. You may get on and off the subway any number of times, and you may switch between different subway lines if you wish. All subway lines go in both directions.
输入
Input consists of the x,y coordinates of your home and your school, followed by specifications of several subway lines. Each subway line consists of the non-negative integer x,y coordinates of each stop on the line, in order. You may assume the subway runs in a straight line between adjacent stops, and the coordinates represent an integral number of metres. Each line has at least two stops. The end of each subway line is followed by the dummy coordinate pair -1,-1. In total there are at most 200 subway stops in the city.
输出
Output is the number of minutes it will take you to get to school, rounded to the nearest minute, taking the fastest route.
样例输入
0 0 10000 1000
0 200 5000 200 7000 200 -1 -1 
2000 600 5000 600 10000 600 -1 -1
样例输出
21
来源
Waterloo local 2001.09.22

注意,memset不能用于float数组的赋值!!!!!!!!

将每个地铁站以及家、学校的位置作为一个点,计算各点之间的距离。


#include <iostream>
#include <stdio.h>
#include <math.h>
#include <climits>
#include <float.h>
#include <string.h>
#include <stdlib.h>

using namespace std;

float graph[205][205];
int cor[205][2];
int station;
bool isvisit[205];
float dis[205];

float getdis(int x1, int y1, int x2, int y2)
{
    return sqrt((x1 - x2) * (x1 - x2) + (y1 - y2) * (y1 - y2));
}

void dijkstra()
{
    for(int i = 0; i < station; i++)
        dis[i] = -1.0;
    memset(isvisit, false, sizeof(isvisit));
    int now = 0;
    isvisit[0] = true;
    dis[0] = 0;
    for(int i = 1; i < station; i++)
    {
        float mindis = -1.0;
        int next = -1;
        for(int j = 1; j < station; j++)
        {
            if(j == now)
                continue;
            if(!isvisit[j])
            {
                if( dis[j] == -1.0 || dis[j] > dis[now] + graph[now][j])
                {
                    dis[j] = dis[now] + graph[now][j];
                }
                if(mindis == -1.0 || dis[j] < mindis)
                {
                    mindis = dis[j];
                    next = j;
                }
            }
        }
        now = next;
        isvisit[now] = true;
    }
}

int main()
{
    //freopen("test.txt", "r", stdin);
    int x0, y0, x1, y1;
    station = 2;

    cin >> x0 >> y0 >> x1 >> y1;
    //cout << x0 << "\t" << y0 << "\t" << x1 << "\t" << y1 << endl;

    cor[0][0] = x0;
    cor[0][1] = y0;
    cor[1][0] = x1;
    cor[1][1] = y1;

    graph[0][1] = graph[1][0] = getdis(x0, y0, x1, y1) / 10000 * 60;

    while(cin >> x0 >> y0)
    {
        //cout << x0 << "\t" << y0 << "\t";
        cor[station][0] = x0;
        cor[station][1] = y0;
        station ++;
        for(int i = 0; i < station -1; i ++)
        {
            graph[i][station - 1] = graph[station - 1][i] = getdis(x0, y0, cor[i][0], cor[i][1]) / 10000 * 60;
            //cout << "graph[" << i << "][" << station - 1 << "]:" << graph[i][station - 1] << endl;
        }
        cin >> x1 >> y1;
        //cout << x1 << "\t" << y1 << "\t" << endl;
        while(x1 != -1 && y1 != -1)
        {
            cor[station][0] = x1;
            cor[station][1] = y1;
            station ++;
            //cout << station << endl;
            for(int i = 0; i < station -2; i ++)
            {
                graph[i][station - 1] = graph[station - 1][i] = getdis(x1, y1, cor[i][0], cor[i][1]) / 10000 * 60;
                //cout << "graph[" << i << "][" << station - 1 << "]:" << graph[i][station - 1] << endl;
            }
            graph[station - 2][station - 1] = graph[station - 1][station - 2] = getdis(x1, y1, cor[station - 2][0], cor[station - 2][1]) / 40000 * 60;
            //cout << "graph[" << station - 2 << "][" << station - 1 << "]:" << graph[station - 2][station - 1] << endl;
            cin >> x1 >> y1;
            //cout << x1 << "\t" << y1 << "\t" << endl;
        }
    }
    dijkstra();
    cout << int(dis[1] + 0.5) << endl;
    return 0;
}






基于STM32F407,使用DFS算法实现最短迷宫路径检索,分为三种模式:1.DEBUG模式,2. 训练模式,3. 主程序模式 ,DEBUG模式主要分析bug,测量必要数据,训练模式用于DFS算法训练最短路径,并将最短路径以链表形式存储Flash, 主程序模式从Flash中….zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值